Hdoj 1247

Posted HackHarry

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Hdoj 1247相关的知识,希望对你有一定的参考价值。

原题链接

描述

A hat’s word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.
You are to find all the hat’s words in a dictionary.

输入

Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 50,000 words.
Only one case.

输出

Your output should contain all the hat’s words, one per line, in alphabetical order.

样例输入

a
ahat
hat
hatword
hziee
word

样例输出

ahat
hatword

思路

字典树。
其他方法需要注意以下情况:
ab
abab
这种情况abab应当输出。

代码

#include <bits/stdc++.h>
#define ll long long
using namespace std;

map<string, int> trie;

int main()
{
    string st1[50002]; int num = 0;
    while(cin >> st1[num])
        trie[st1[num++]] = 1;
    for(int i = 0; i < num; i++)
    {
        int len = st1[i].size();
        string st2 = "";
        int f = 0;
        for(int j = 0; j < len - 1; j++)
        {
            st2 += st1[i][j];
            if(trie[st2])
            {
                string st3 = "";
                for(int k = j + 1; k < len; k++)
                {
                    st3 += st1[i][k];
                }
                if(trie[st3]) f = 1;
            }
            if(f) break;
        }
        if(f) cout << st1[i] << endl;
    }
    return 0;
}

以上是关于Hdoj 1247的主要内容,如果未能解决你的问题,请参考以下文章

Hat’s Words HDU1247

P1243~P1247 线段树模板题总结

hdu-1247

水题(用map)--hdu1247

codeforces 1247C

P1247 取火柴游戏(异或理论)