6-7 在一个数组中实现两个堆栈(20 分)
本题要求在一个数组中实现两个堆栈。
函数接口定义:
Stack CreateStack( int MaxSize );
bool Push( Stack S, ElementType X, int Tag );
ElementType Pop( Stack S, int Tag );
其中Tag
是堆栈编号,取1或2;MaxSize
堆栈数组的规模;Stack
结构定义如下:
typedef int Position;
struct SNode {
ElementType *Data;
Position Top1, Top2;
int MaxSize;
};
typedef struct SNode *Stack;
注意:如果堆栈已满,Push
函数必须输出“Stack Full”并且返回false;如果某堆栈是空的,则Pop
函数必须输出“Stack Tag Empty”(其中Tag是该堆栈的编号),并且返回ERROR。
裁判测试程序样例:
#include <stdio.h>
#include <stdlib.h>
#define ERROR 1e8
typedef int ElementType;
typedef enum { push, pop, end } Operation;
typedef enum { false, true } bool;
typedef int Position;
struct SNode {
ElementType *Data;
Position Top1, Top2;
int MaxSize;
};
typedef struct SNode *Stack;
Stack CreateStack( int MaxSize );
bool Push( Stack S, ElementType X, int Tag );
ElementType Pop( Stack S, int Tag );
Operation GetOp(); /* details omitted */
void PrintStack( Stack S, int Tag ); /* details omitted */
int main()
{
int N, Tag, X;
Stack S;
int done = 0;
scanf("%d", &N);
S = CreateStack(N);
while ( !done ) {
switch( GetOp() ) {
case push:
scanf("%d %d", &Tag, &X);
if (!Push(S, X, Tag)) printf("Stack %d is Full!\n", Tag);
break;
case pop:
scanf("%d", &Tag);
X = Pop(S, Tag);
if ( X==ERROR ) printf("Stack %d is Empty!\n", Tag);
break;
case end:
PrintStack(S, 1);
PrintStack(S, 2);
done = 1;
break;
}
}
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
5
Push 1 1
Pop 2
Push 2 11
Push 1 2
Push 2 12
Pop 1
Push 2 13
Push 2 14
Push 1 3
Pop 2
End
输出样例:
Stack 2 Empty
Stack 2 is Empty!
Stack Full
Stack 1 is Full!
Pop from Stack 1: 1
Pop from Stack 2: 13 12 11
思路:该指针是一维的,所以要用数组实现两个堆栈。我有两种想法申请一个2*MaxSize+1的数组,从中间开始分别加减实现两个栈,但是碰到输出超限,于是我打算补齐两个 /* details omitted */函数(细节决定成败,你却给我省略了)\脑疼??;然后试了第二种申请大小为MaxSize的数组,从两头开始向中。然而还是输出超限。。。。我要去百度了拜拜~
看完答案之后—>这种题目目的是为了让我们猜输出函数???简直浪费表情
两细节省略函数如下:
Operation GetOp() { char Push[] = "Push"; char Pop[] = "Pop"; char End[] = "End"; char s[100]; scanf("%s", s); if (strcmp(Push, s) == 0)return push; if (strcmp(Pop, s) == 0)return pop; if (strcmp(End, s) == 0)return end; } void PrintStack(Stack S, int Tag) { printf("Pop from Stack %d:", Tag); if (Tag == 1){ while (S->Top1 != -1){ printf(" %d", S->Data[S->Top1--]); } } else { while (S->Top2 != S->MaxSize){ printf(" %d", S->Data[S->Top2++]); } } putchar(‘\n‘); }
AC代码如下:
Stack CreateStack(int MaxSize) { Stack stack = (Stack)malloc(sizeof(struct SNode)); stack->Data = (int *)malloc(sizeof(ElementType)* MaxSize); stack->Top1 = -1; stack->Top2 = MaxSize; stack->MaxSize = MaxSize; return stack; } bool Push(Stack S, ElementType X, int Tag) { if (S == NULL)return false; if (S->Top1+1==S->Top2){ printf("Stack Full\n"); return false; } if (Tag == 1) S->Data[++S->Top1] = X; else S->Data[--S->Top2] = X; return true; } ElementType Pop(Stack S, int Tag) { if (S == NULL)return ERROR; if (Tag == 1){ if (S->Top1 == -1) { printf("Stack %d Empty\n",Tag); return ERROR; } return S->Data[S->Top1--]; } if (S->Top2 == S->MaxSize) { printf("Stack %d Empty\n", Tag); return ERROR; } return S->Data[S->Top2++]; }