Hdoj 2058

Posted HackHarry

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Hdoj 2058相关的知识,希望对你有一定的参考价值。

原题链接

描述

Given a sequence 1,2,3,......N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.

输入

Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.

输出

For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.

样例输入

20 10
50 30
0 0

样例输出

[1,4][10,10]

[4,8][6,9]
[9,11][30,30]

思路

等差数列求和的变形。
\(S=\frac{(k+k+n-1)*n}{2}\)
\(2k=\frac{2s}{n}-n+1, n≤\sqrt{S}\)
枚举n然后算出k就好

代码

#include <bits/stdc++.h>
#define ll long long
using namespace std;

int main()
{
    ll n, m;
    while(~scanf("%lld %lld", &n, &m))
    {
        if(n + m == 0) break;
        ll k, t;
        for(t = sqrt(2 * m); t > 0; t--)
        {
            if(2 * m % t) continue;
            ll r = 2 * m / t - t + 1;
            if(r % 2) continue;
            k = r >> 1;
            printf("[%lld,%lld]\n", k, k + t - 1);
        }
        printf("\n");
    }
    return 0;
}

以上是关于Hdoj 2058的主要内容,如果未能解决你的问题,请参考以下文章

Hdoj 2058

在 C# 中连接到 Websphere MQ 有效,但在 C++ 中失败,代码为 2058 (MQRC_Q_MGR_NAME_ERROR)

Luogu P2058 海港

AcWing 2058. 笨拙的手指(暴力枚举)

2058. 找出临界点之间的最小和最大距离 的 详细解法(遍历链表)

AcWing 1月9日每日一题 2058. 笨拙的手指