PAT 1063. Set Similarity

Posted A-Little-Nut

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了PAT 1063. Set Similarity相关的知识,希望对你有一定的参考价值。

Given two sets of integers, the similarity of the sets is defined to be Nc/Nt*100%, where Nc is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (<=50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (<=104) and followed by M integers in the range [0, 109]. After the input of sets, a positive integer K (<=2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

Sample Output:

50.0%
33.3%

分析
用set做比较简单,每个集合用一个set储存,这样set里都不会有重复的元素,nc就是两个set中相同元素的对数,nt是两个set的size之和再减去nc.

#include<iostream>
#include<set>
using namespace std;
int main(){
    int n,m,t,p1,p2;
    cin>>n;
    set<long int> sets[n+1];
    for(int i=1;i<=n;i++){
        cin>>m;
        for(int j=0;j<m;j++){
            cin>>t;
            sets[i].insert(t);
        }
    }
    cin>>n;
    for(int i=0;i<n;i++){
        double nc=0,nt;
        cin>>p1>>p2;
        for(auto it=sets[p1].begin();it!=sets[p1].end();it++){
            if(sets[p2].find(*it)!=sets[p2].end())
               nc++;
        }
        double temp=nc/(sets[p1].size()+sets[p2].size()-nc)*100;
        printf("%.1lf%\n",temp);
    }
    return 0;
} 

以上是关于PAT 1063. Set Similarity的主要内容,如果未能解决你的问题,请参考以下文章

PAT 1063. Set Similarity

PAT Advanced 1063 Set Similarity (25分)(STL)

PAT 甲级 1063 Set Similarity (25 分) (新学,set的使用,printf 输出%,要%%)

PAT (Advanced Level) 1063. Set Similarity (25)

PAT甲题题解-1063. Set Similarity (25)-set的使用

1063 Set Similarity