poj2356鸽舍原理

Posted 不积跬步无以至千里,不积小流无以成江海

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了poj2356鸽舍原理相关的知识,希望对你有一定的参考价值。

        The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).

Input

The first line of the input contains the single number N. Each of next N lines contains one number from the given set.

Output

In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate line each) in arbitrary order.

If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.

Sample Input

5
1
2
3
4
1

Sample Output

2
2
3
#include<stdio.h>
#include<string.h>
int n,c;
int a[100010],b[100010],vis[100010],sum[100010];
int main()
{

    while(scanf("%d",&n)!=EOF)
    {
        int x,y;
        memset(vis,-1,sizeof(vis));
        memset(sum ,0,sizeof(sum));
        vis[0] = 0;//前i项可以被c整除
        for(int i=1;i<=n;i++){
            scanf("%d",&a[i]);
            sum[i]=(a[i]+sum[i-1])%n;
            if(vis[sum[i]]==-1)
                vis[sum[i]] = i;
            else
            {
                x = vis[sum[i]];//vis[sum[i]] = i;记录了上一次的i
                y = i;
            }
        }
            printf("%d\n",y-x);
            for(int i = x+1;i <= y;i++)
                    printf("%d\n",a[i]);
    }
    return 0;
}

 

以上是关于poj2356鸽舍原理的主要内容,如果未能解决你的问题,请参考以下文章

代码源 Div1 - 106#456. 选数(抽屉原理) POJ2356

poj 2356 (抽屉原理)

[POJ2356]Find a multiple 题解(鸽巢原理)

B - 抽屉 POJ - 2356 (容斥原理)

POJ 2356. Find a multiple 抽屉/鸽巢原理

[POJ2356] Find a multiple 鸽巢原理