PAT 1053. Path of Equal Weight

Posted A-Little-Nut

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了PAT 1053. Path of Equal Weight相关的知识,希望对你有一定的参考价值。

Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let‘s consider the tree showed in Figure 1: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in Figure 1.

技术分享图片
       Figure 1

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0 < N <= 100, the number of nodes in a tree, M (< N), the number of non-leaf nodes, and 0 < S < 230, the given weight number. The next line contains N positive numbers where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID‘s of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A1, A2, ..., An} is said to be greater than sequence {B1, B2, ..., Bm} if there exists 1 <= k < min{n, m} such that Ai = Bi for i=1, ... k, and Ak+1 > Bk+1.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

分析

我觉得这道题还是很oK的,用邻接表方式储存子节点,并对每个父节点所有的子节点按权重排序,再用dfs,在dfs中保存路径,当dfs到叶节点时,即该节点的邻接表为空时,判断该条路径的和是否与题目要求的相等,相等则输出路径。注意在每次对一个节点的所有邻接表中的节点访问后,就要pop出,sum也要减去相应节点的weight,以维持路径和sum的正确性。
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
int weight[101],n,m,s,father,son,num,pre[101];
vector<int> list[101],res;
bool cmp(const int& n,const int& m){
    return weight[n]>weight[m];
}
void dfs(int root,int sum){
    res.push_back(weight[root]);
    sum+=weight[root];
    if(list[root].size()==0){
        if(sum==s){
            for(int i=0;i<res.size();i++)
            i>0?cout<<" "<<res[i]:cout<<res[i];
            cout<<endl;
        }
        sum-=res[res.size()-1];
        res.pop_back();
        return ;
    }
    for(int i=0;i<list[root].size();i++)
        dfs(list[root][i],sum);
    sum-=res[res.size()-1];
    res.pop_back();
}
int main(){
    cin>>n>>m>>s;
    for(int i=0;i<n;i++)
        cin>>weight[i];
    for(int i=0;i<m;i++){
        cin>>father>>num;
        for(int j=0;j<num;j++){
            cin>>son;
            list[father].push_back(son);
        }
        sort(list[father].begin(),list[father].end(),cmp);
    }
    dfs(0,0);
    return 0;
}

以上是关于PAT 1053. Path of Equal Weight的主要内容,如果未能解决你的问题,请参考以下文章

PAT甲题题解-1053. Path of Equal Weight (30)-dfs

PAT 1053. Path of Equal Weight

PAT 1053 Path of Equal Weight (30)

PAT 1053. Path of Equal Weight (30)

PAT Advanced Level 1053 Path of Equal Weight

PAT Advanced 1053 Path of Equal Weight (30) [树的遍历]