PAT 1048. Find Coins

Posted A-Little-Nut

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了PAT 1048. Find Coins相关的知识,希望对你有一定的参考价值。

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=105, the total number of coins) and M(<=103, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V1 and V2 (separated by a space) such that V1 + V2 = M and V1 <= V2. If such a solution is not unique, output the one with the smallest V1. If there is no solution, output "No Solution" instead.

Sample Input 1:

8 15
1 2 8 7 2 4 11 15

Sample Output 1:

4 11

Sample Input 2:

7 14
1 8 7 2 4 11 15

Sample Output 2:

No Solution

分析
这题比较简单,应该属于散列吧

#include<iostream>
using namespace std;
int face[501]={0};
int main(){
    int n,m,num;
    cin>>n>>m;
    for(int i=0;i<n;i++){
        cin>>num;
        face[num]++;
    }
    for(int i=1;i<=500;i++){
        if(face[i]==0) continue;
        face[i]--;
        if(m-i>0&&m-i<=500&&face[m-i]>=1){
           cout<<i<<" "<<m-i<<endl;
           return 0;
        }
    }
    cout<<"No Solution"<<endl;
    return 0;
}

以上是关于PAT 1048. Find Coins的主要内容,如果未能解决你的问题,请参考以下文章

PAT 1048. Find Coins

PAT 甲级 1048 Find Coins

PAT甲级1048 Find Coins (25 分)(二分)

1048. Find Coins (25)

1048. Find Coins (25)

1048 Find Coins(二分法解法)