AC日记 - - - 19——分割整数

Posted 一本故事i

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了AC日记 - - - 19——分割整数相关的知识,希望对你有一定的参考价值。

Problem Description

从键盘输入一个长整数(不超过10位),从高位开始逐位分割并输出。

Input

正整数n,不含前导零。

Output

分割的整数序列,各整数之间用空格格开。
注意,最后一个数字后面没有空格!

Example Input

654321

Example Output

6 5 4 3 2 1

Hint

 

#include <stdio.h>
#include <stdlib.h>
int main()
{
    char num[10];
    int i;
    scanf("%s", &num);
    for(i=0; i<strlen(num); i++)
    {
        if(i==0)
        printf("%c", num[i]);
        else
        printf(" %c", num[i]);
    }

}

  

以上是关于AC日记 - - - 19——分割整数的主要内容,如果未能解决你的问题,请参考以下文章

AC日记 - - - 27——矩阵输出

Ac日记——大整数减法 openjudge 1.6 11

AC日记——大整数加法 openjudge 1.6 10

AC日记——元素查找 codevs 1230

AC日记 - - - 18——区间之和

AC日记 - - - 21——数组逆序