PAT 1001. A+B Format

Posted A-Little-Nut

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了PAT 1001. A+B Format相关的知识,希望对你有一定的参考价值。

PAT 1001. A+B Format

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

-1000000 9

Sample Output

-999,991

代码如下

#include<iostream>
using namespace std;
int main(){
    int a,b,cnt=0;
    cin>>a>>b;
    a+=b;
    string s;
    s=to_string(a);
    int t=a<0?2:1;
    for(int i=s.length()-1;i>=t;i--){
        cnt++;
        if(cnt%3==0){
        s.insert(i,1,',');
        cnt=0;  
        }   
    }
    cout<<s;
    return 0;
}

以上是关于PAT 1001. A+B Format的主要内容,如果未能解决你的问题,请参考以下文章

PAT 1001. A+B Format

PAT 1001 A+B Format

PAT1001. A+B Format (20)

PAT-甲级-1001-A+B Format

PAT A1001 A+B Format

PAT 1001. A+B Format (20)