POJ1308 Is It A Tree?

Posted BobHuang

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ1308 Is It A Tree?相关的知识,希望对你有一定的参考价值。

Is It A Tree?

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

There is exactly one node, called the root, to which no directed edges point. 
Every node except the root has exactly one edge pointing to it. 
There is a unique sequence of directed edges from the root to each node. 
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not. 
技术分享图片

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

这个就是判断给定数据是不是有根树,这个可以根据我们学的那个概念来,就是G无回路且m=n-1

需要注意的几组数据

1: 0 0 空树是一棵树
2: 1 1 0 0 不是树 不能自己指向自己
3: 1 2 1 2 0 0 不是树....自己开始一直在这么WA  好郁闷 重复都不行呀~~5555
4: 1 2 2 3 4 5 不是树  森林不算是树(主要是注意自己)
5: 1 2 2 3 3 4 4 5 5 6 6 7 7 8 8 9 9 1  注意 一个节点在指向自己的父亲或祖先 都是错误的 即 9-->1 错
6: 1 2 2 1 0 0 也是错误的
高高高,这离散学得不错
#include<stdio.h>
int main()
{
    int T=0,u,v;
    while(scanf("%d%d",&u,&v),~u||~v)
    {
        int ver[128]={0},fa[128]={0},nu=0,nv=0,f=1;
        if(u)
        {do
        {
          if(!fa[v])fa[v]=u;
          else f=0;
          if(!ver[u])ver[u]=1,nv++;
          if(!ver[v])nv++;
          ver[u]=ver[v]=1;
          nu++;
        }while(scanf("%d%d",&u,&v),u||v);
        if(nu!=nv-1)f=0;
        }
        printf("Case %d is ",++T);
        if(!f)printf("not ");
        puts("a tree.");
    }
    return 0;
}

 









以上是关于POJ1308 Is It A Tree?的主要内容,如果未能解决你的问题,请参考以下文章

POJ - 1308 Is It A Tree?并查集

POJ 1308 Is It A Tree? [并查集]

POJ 1308 Is It A Tree?

POJ 1308 Is It A Tree?--题解报告

POJ-1308 Is It A Tree?(并查集判断是否是树)

HDU 1325 POJ 1308 Is It A Tree? (并查集)