LightOJ - 1354 IP Checking

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了LightOJ - 1354 IP Checking相关的知识,希望对你有一定的参考价值。

Time Limit: 2000MS   Memory Limit: 32768KB   64bit IO Format: %lld & %llu

Status

Description

An IP address is a 32 bit address formatted in the following way

a.b.c.d

where a, b, c, d are integers each ranging from 0 to 255. Now you are given two IP addresses, first one in decimal form and second one in binary form, your task is to find if they are same or not.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with two lines. First line contains an IP address in decimal form, and second line contains an IP address in binary form. In binary form, each of the four parts contains 8 digits. Assume that the given addresses are valid.

Output

For each case, print the case number and "Yes" if they are same, otherwise print "No".

Sample Input

2

192.168.0.100

11000000.10101000.00000000.11001000

65.254.63.122

01000001.11111110.00111111.01111010

Sample Output

Case 1: No

Case 2: Yes

Source

Problem Setter: Jane Alam Jan
取数注意循环终止条件 ;
#include <cstdio>
#include <cstring>
int main()
{
    int c[5], d[5];
    char a[40], b[40];    
    int t, Qt=1; scanf("%d", &t);
    while(t--)
    {
        scanf("%s%s", a, b);
        int indexc=0, sum=0;
        int lena=strlen(a);
        for(int i=0; i<=lena; i++)
        {
            if(a[i]==.||i==lena)
            {
                c[indexc++]=sum; sum=0;
            }
            else
                sum=sum*10+a[i]-0;
        }
        
        int indexd=0, Q=1; sum=0;
        int lenb=strlen(b);
        for(int i=lenb-1; i>=-1; i--) 
        {
            if(b[i]==.||i==-1)
            {
                d[indexd++]=sum;
                Q=1; sum=0;
            }
            else
            {
                sum=sum+(b[i]-0) *Q;
                Q *=2;
            }
        }
        
        int i; 
        for(i=0; i< 4; i++)
            if(c[i] != d[3-i])
                break;
        printf("Case %d: ", Qt++);
        if(i==4)
            printf("Yes\n");
        else
            printf("No\n");
    }
}                         

 

以上是关于LightOJ - 1354 IP Checking的主要内容,如果未能解决你的问题,请参考以下文章

51nod 1354:选数字

题解选数字 [51nod1354]

UVa 1354 天平难题

P1354 房间最短路问题(建图&最短路)

UVa 1354 Mobile Computing[暴力枚举]

uva1354 天平难题 解题报告