7-14 电话聊天狂人(25 分)

Posted 给杰瑞一块奶酪~

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了7-14 电话聊天狂人(25 分)相关的知识,希望对你有一定的参考价值。

给定大量手机用户通话记录,找出其中通话次数最多的聊天狂人。

输入格式:

输入首先给出正整数N(10?5??),为通话记录条数。随后N行,每行给出一条通话记录。简单起见,这里只列出拨出方和接收方的11位数字构成的手机号码,其中以空格分隔。

输出格式:

在一行中给出聊天狂人的手机号码及其通话次数,其间以空格分隔。如果这样的人不唯一,则输出狂人中最小的号码及其通话次数,并且附加给出并列狂人的人数。

输入样例:

4
13005711862 13588625832
13505711862 13088625832
13588625832 18087925832
15005713862 13588625832

输出样例:

13588625832 3


首先想到的是排序。
代码:
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
char s[200000][12];
int cmp(const void *a,const void *b)
{
    return strcmp((char*)a,(char*)b)>0?1:-1;
}
int main()
{
    int n;
    int c = 1,d = 1;
    int maxi = 0;
    char ans[12] = "00000000000";
    scanf("%d",&n);
    for(int i = 0;i < n;i ++)
    {
        scanf("%s%s",s[i*2],s[i*2+1]);
    }
    qsort(s,2*n,sizeof(s[0]),cmp);
//    for(int i = 0;i < n * 2 + 1;i ++)
//        printf("%s\n",s[i]);
    for(int i = 1;i < n * 2 + 1;i ++)
    {
        if(strcmp(s[i],s[i - 1]) == 0)d ++;
        else
        {
            if(d>maxi)
            {
                strcpy(ans,s[i - 1]);
                maxi = d;
                c = 1;
            }
            else if(d == maxi)
            {
                c ++;
            }
            d = 1;
        }
    }
    printf("%s %d",ans,maxi);
    if(c>1)printf(" %d",c);
}

然后用哈希的分离链接法,就是先建一个一定大小的桶,每个号码对桶的大小(是个素数)取余,存进去,如果号码已存在就覆盖并记录个数,余数相同的存到同一个位置的一条链中,跟链表一样。最后扫描一遍出答案。

代码:

#include <stdio.h>
#include <stdlib.h>

typedef struct loca loca;
typedef struct hashh hashh;
struct loca
{
    long long data;
    int c;
    loca *_next;
};
struct hashh
{
    int hsize;
    loca **har;
};
hashh *creathash(int n)
{
    hashh *h = (hashh *)malloc(sizeof(hashh));
    h -> hsize = n;
    h -> har = (loca **)malloc(sizeof(loca*) * n);
    for(int i = 0;i < h -> hsize;i ++)
    {
        h -> har[i] = (loca *)malloc(sizeof(loca));
        h -> har[i] -> _next = NULL;
    }
    return h;
}
void inserthash(long long n,hashh *h)
{
    int d = n % h -> hsize;
    loca *pos = h -> har[d];
    while(pos -> _next)
    {
        if(pos -> _next -> data == n)
        {
            pos -> _next -> c ++;
            return;
        }
        pos = pos -> _next;
    }
    pos -> _next = (loca *)malloc(sizeof(loca));
    pos -> _next -> data = n;
    pos -> _next -> c = 1;
    pos -> _next -> _next = NULL;
}
void findans(hashh *h)
{
    long long d = 0;
    int maxc = 0,c;
    for(int i = 0;i < h -> hsize;i ++)
    {
        loca *p = h -> har[i] -> _next;
        while(p)
        {
            if(p -> c > maxc)maxc = p -> c,d = p -> data,c = 0;
            else if(p -> c == maxc)
            {
                c ++;
                if(p -> data < d)d = p -> data;
            }
            p = p -> _next;
        }
    }
    printf("%lld %d",d,maxc);
    if(c)printf(" %d",c + 1);
}
int isprime(int n)
{
    if(n == 2 || n == 3)return 1;
    if(n % 6 != 1 && n % 6 != 5)return 0;
    for(int i = 5;i * i <= n;i += 6)
    {
        if(n % i == 0 || n % (i + 2) == 0)return 0;
    }
    return 1;
}
int nextprime(int n)
{
    if(n % 2 == 0)n ++;
    while(!isprime(n))n += 2;
    return n;
}
int main()
{
    int n;
    long long a,b;
    scanf("%d",&n);
    hashh *h = creathash(nextprime(n * 2));///创建哈希表
    for(int i = 0;i < n;i ++)
    {
        scanf("%lld%lld",&a,&b);
        inserthash(a,h);
        inserthash(b,h);
    }
    findans(h);///遍历出答案
}

好像还可以用二叉搜索树,就不尝试了。估计跟排序差不多。

以上是关于7-14 电话聊天狂人(25 分)的主要内容,如果未能解决你的问题,请参考以下文章

5-14 电话聊天狂人 (25分)

7-113 电话聊天狂人 (25分)

11-散列1 电话聊天狂人 (25 分)

PTA 5-14 电话聊天狂人 (25分)

基础实验5-2.2 电话聊天狂人 (25分)-散列表

电话聊天狂人