1138. Postorder Traversal (25)

Posted 给杰瑞一块奶酪~

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1138. Postorder Traversal (25)相关的知识,希望对你有一定的参考价值。

Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences, you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=50000), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the first number of the postorder traversal sequence of the corresponding binary tree.

Sample Input:
7
1 2 3 4 5 6 7
2 3 1 5 4 7 6
Sample Output:
3

后序遍历的顺序是先左右再树根,那么就一层一层来如果左子树不为空,那么答案一定在左子树,否则如果右子树不为空,那么答案一定在右子树,如果都不行,那么答案就是树根。
代码:
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
#include <iostream>
#include <map>
using namespace std;
int q[50000],z[50000];
int n;
int findpostfirst(int q1,int q2,int z1,int z2)
{
    for(int i = z1;i <= z2;i ++)
    {
        if(z[i] == q[q1])
        {
            if(i != z1)return findpostfirst(q1+1,q1+i-z1,z1,i-1);
            else if(i != z2) return findpostfirst(q1+i-z1+1,q2,i+1,z2);
            else return q[q1];
        }
    }
}
int main()
{
    cin>>n;
    for(int i = 0;i < n;i ++)
    {
        cin>>q[i];
    }
    for(int i = 0;i < n;i ++)
    {
        cin>>z[i];
    }
    cout<<findpostfirst(0,n-1,0,n-1);
}

 

以上是关于1138. Postorder Traversal (25)的主要内容,如果未能解决你的问题,请参考以下文章

PAT1138Postorder Traversal(25)

1138 Postorder Traversal (25)

1138 Postorder Traversal(先序+中序=二叉树)

1138 Postorder Traversal (25 分)难度: 一般 / 知识点: 建树

**Binary Tree Postorder Traversal

PAT甲级——A1138 Postorder Traversa25