1044. Shopping in Mars (25)

Posted 给杰瑞一块奶酪~

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1044. Shopping in Mars (25)相关的知识,希望对你有一定的参考价值。

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=105), the total number of diamonds on the chain, and M (<=108), the amount that the customer has to pay. Then the next line contains N positive numbers D1 ... DN (Di<=103 for all i=1, ..., N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print "i-j" in a line for each pair of i <= j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output "i-j" for pairs of i <= j such that Di + ... + Dj > M with (Di + ... + Dj - M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:
16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13
Sample Output 1:
1-5
4-6
7-8
11-11
Sample Input 2:
5 13
2 4 5 7 9
Sample Output 2:
2-4
4-5

先计算前缀和,然后i-j的和就是sum[i]-sum[j-1],保留sum[0]为0,但是会有一个点超时,然后加上二分。

代码:
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <map>
#include <cmath>
using namespace std;
struct xy
{
    int x, y;
}s[100000];
int main()
{
    int a,sum[100001] = {0};
    int n,m,mi = 1000000000,c;
    scanf("%d%d",&n,&m);
    for(int i = 1;i <= n;i ++)
    {
        scanf("%d",&a);
        sum[i] = sum[i - 1] + a;
        int l = 0,r = i - 1,mid = (l + r)/2;
        while(l <= r)
        {
            if(sum[i] - sum[mid] < m)r = mid - 1;
            else l = mid + 1;
            mid = (l + r)/2;
        }
        int d = sum[i] - sum[mid];
        if(d >= m)
        {
            if(d < mi)mi = d,c = 0;
            else if(d > mi)continue;
            s[c].x = mid + 1;
            s[c ++].y = i;
        }
    }
    for(int i = 0;i < c;i ++)
    printf("%d-%d\n",s[i].x,s[i].y);
}

 

以上是关于1044. Shopping in Mars (25)的主要内容,如果未能解决你的问题,请参考以下文章

1044. Shopping in Mars (25)

1044. Shopping in Mars (25)

PAT 1044. Shopping in Mars

PAT 1044 Shopping in Mars[二分][难]

PAT甲级——A1044 Shopping in Mars

PTA(Advanced Level)1044.Shopping in Mars