HDU3037Saving Beans(组合数+lucas定理)

Posted ---学习ing---

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU3037Saving Beans(组合数+lucas定理)相关的知识,希望对你有一定的参考价值。

Problem Description

Although winter is far away, squirrels have to work day and night to save beans. They need plenty of food to get through those long cold days. After some time the squirrel family thinks that they have to solve a problem. They suppose that they will save beans in n different trees. However, since the food is not sufficient nowadays, they will get no more than m beans. They want to know that how many ways there are to save no more than m beans (they are the same) in n trees.

Now they turn to you for help, you should give them the answer. The result may be extremely huge; you should output the result modulo p, because squirrels can’t recognize large numbers.
 

 

Input

The first line contains one integer T, means the number of cases.

Then followed T lines, each line contains three integers n, m, p, means that squirrels will save no more than m same beans in n different trees, 1 <= n, m <= 1000000000, 1 < p < 100000 and p is guaranteed to be a prime.
 

 

Output

You should output the answer modulo p.
 

 

Sample Input

2
1 2 5
2 1 5
 

 

Sample Output

3
3

Hint

Hint For sample 1, squirrels will put no more than 2 beans in one tree. Since trees are different, we can label them as 1, 2 … and so on. The 3 ways are: put no beans, put 1 bean in tree 1 and put 2 beans in tree 1. For sample 2, the 3 ways are: put no beans, put 1 bean in tree 1 and put 1 bean in tree 2.

题意:

在n棵树上摘不超过m个果子,果子是一样的,问取法,结果膜p。

思路:

由隔板法或者母函数都可以得到结果是Σ(i=1˜n)   Cn+m-1(i) % p=Cn+m (m) %p。然后套Lucas的模板即可。

 

#include<cstdio>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
#define LL long long
const int maxn=100010;
LL fac[maxn],Mod;
void factorial()
{
    fac[0]=1;  for(int i=1;i<=Mod;i++) fac[i]=fac[i-1]*i%Mod;
}
LL f_pow(LL a,LL x)
{
    LL res=1; a%=Mod;
    while(x){  if(x&1) res=res*a%Mod;a=a*a%Mod; x>>=1; }return res;
}
LL Cm(LL n,LL m)
{
    if(m>n) return 0; return fac[n]*f_pow(fac[m]*fac[n-m]%Mod,Mod-2)%Mod;
}
LL Lucas(LL n,LL m)
{
    if(m==0) return 1;  return Cm(n%Mod,m%Mod)*Lucas(n/Mod,m/Mod)%Mod; 
}
int main()
{
    LL n,m,T;scanf("%lld",&T);
    while(T--){
         scanf("%lld%lld%lld",&n,&m,&Mod);
         factorial();
         printf("%lld\n",Lucas(n+m,m));
    } return 0;
}

 

以上是关于HDU3037Saving Beans(组合数+lucas定理)的主要内容,如果未能解决你的问题,请参考以下文章

HDU 3037 Saving Beans(Lucas定理的直接应用)

「题解」「HDU3037」Saving Beans

HDU 3037 Saving Beans

HDU 3037 Saving Beans (隔板法+Lucas定理)

hdu 3037 Saving Beans

HDU 3037:Saving Beans