1032. Sharing (25)

Posted 给杰瑞一块奶酪~

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1032. Sharing (25)相关的知识,希望对你有一定的参考价值。

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, "loading" and "being" are stored as showed in Figure 1.

技术分享图片
Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of "i" in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (<= 105), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output "-1" instead.

Sample Input 1:
11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010
Sample Output 1:
67890
Sample Input 2:
00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1
Sample Output 2:
-1


代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <map>
#define Max 10005
using namespace std;
struct node
{
    char Data;
    int Next;
}s[100000];
int n,a,b,q = -1;
int main()
{
    map<int,int> p;
    int Address,Next;
    char Data;
    cin>>a>>b>>n;
    for(int i = 0;i < n;i ++)
    {
        scanf("%d %c %d",&Address,&Data,&Next);
        s[Address].Data = Data;
        s[Address].Next = Next;
    }
    while(a != -1)
    {
        if(p[a])break;
        p[a] = 1;
        a = s[a].Next;
    }
    while(b != -1)
    {
        if(p[b])
        {
            q = b;
            break;
        }
        b = s[b].Next;
    }
    if(q != -1)printf("%05d",q);
    else printf("%d",q);
}

 

以上是关于1032. Sharing (25)的主要内容,如果未能解决你的问题,请参考以下文章

1032. Sharing (25)

1032 Sharing (25分)(数组链表)

PAT Advanced 1032 Sharing(25) [链表]

PAT 1032 Sharing (25分) 从自信到自闭

PAT 1032 Sharing (25分) 从自信到自闭

PAT (Advanced Level) 1032. Sharing (25)