HDU 1518 Square (DFS+剪枝)

Posted Farewell

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 1518 Square (DFS+剪枝)相关的知识,希望对你有一定的参考价值。

Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?
Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.
Output
For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".
Sample Input
3
4 1 1 1 1
5 10 20 30 40 50
8 1 7 2 6 4 4 3 5
Sample Output
yes
no
yes

题意:

用所有的木棒首尾相连,问能否组成一个正方形。

题解:

DFS搜索,另外对一些情况进行剪枝。

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int a[50];
bool vis[50];
int ave;
bool flag;
int n;
void dfs(int cnt,int sum,int k)
{
    if(flag) return ;
    if(cnt==3)//前3个边都选好了,那么最后一条边一定能满足
    {
        flag=true;
        return ;
    }
    for(int i=k;i<n;i++)
    {
        if(!vis[i]&&a[i]+sum<=ave)
        {
            vis[i]=true;
            if(sum+a[i]==ave)
                dfs(cnt+1,0,0);
            else
                dfs(cnt,sum+a[i],i+1);
            if(flag) return ;
            vis[i]=false;
        }
    }
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        cin>>n;
        int sum=0;
        for(int i=0;i<n;i++)
            cin>>a[i],sum+=a[i];
        if(sum%4)//剪枝,如果不能被4整除,一定不能组成四边形
        {
            cout<<"no"<<endl;
            continue;
        }
        ave=sum/4;
        flag=false;
        memset(vis,false,sizeof(vis));
        dfs(0,0,0);
        if(flag)
            cout<<"yes"<<endl;
        else
            cout<<"no"<<endl;
    }
    return 0;
}

以上是关于HDU 1518 Square (DFS+剪枝)的主要内容,如果未能解决你的问题,请参考以下文章

DFS——hdu1518Square

hdu 1518 Square 木棍建正方形DFS

hdu 1518 Square

hdoj 1518 Square dfs

HDU1518:Square

HDU - 1518 :Square