kuangbin专题五:B - The Suspects POJ - 1611

Posted 0一叶0知秋0

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了kuangbin专题五:B - The Suspects POJ - 1611相关的知识,希望对你有一定的参考价值。

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n?1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
4
1
1
题意:给 n 个学生 0--n-1 顺序编号 , 然后 第 0 号 同学被认为是 传染病嫌疑者 , 之后 有 m 个团体 ,
   后面 m 行 , 每行 第一个数字 k 表示 这个团体有 k 个人 , 之后 k 个数字 表示 这个团体内同学的编号
   最后 统计 多少个人 是 传染病的怀疑者 (与第 0 号 同学 同一个集合的同学有多少位)
思路:并查集 模板题目

技术分享图片
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>

using namespace std ; 

#define maxn 50000
int father[maxn] ; 
int n , m , k ;  
int num[maxn] ; 
// 初始化 编号 , 每一个元素都是一个 集合
void init(){
    for(int i=0 ; i<=n ; i++){
        father[i] = i ; 
    }
    return;
}
// 查找 x 元素 所在集合的代表元素的 编号 
// 同时 理顺 上一次 对本集合 合并 
// 导致的部分成员 没有指向代表元素 
int find(int x){
    if(x!=father[x]){
        father[x] = find(father[x]) ; 
    }
    return father[x] ; 
}
// y 所在集合 所有元素 都指向 rooty
// x 所在集合 所有元素 都指向 rootx
// 如果 x y 不是 统一集合 ,则把 y 集合的代表元素 指向 x 集合的代表元素 rootx
// 上述方法实现合并 , 会导致 一部分 y 集合元素 没有指向 rootx 
// 这种情况 会在 下一次 调用 find() 函数 时 解决
void Union_set(int x , int y){
    int rootx = find(x) ; 
    int rooty = find(y) ; 
    if(rootx!=rooty){
        father[rooty] = rootx ; 
    }
}
// 通过检查 两元素 的所在集合的代表元素 是否相等 来判断两元素是不是统一集合的元素
bool check(int x , int y){
    return find(x) == find(y) ; 
}

int main(){

    while(~scanf("%d %d" , &n , &m)){
        if(n==0&&m==0){
            break ; 
        }
        init() ; 

        for(int i=1 ; i<=m ; i++){
            scanf("%d" ,&k) ; 

            for(int j=1 ; j<=k ;  j++){
                scanf("%d" , &num[j]) ; 
            }

            for(int j=1 ; j<k ; j++){
                Union_set(num[j] , num[j+1]) ; 
            }
        }

        int result = 0 ; 
        for(int i=0 ; i<n ; i++){
            // 和 0 号 同学是 同一集合的 同学都是 嫌疑人
            if(check(i , 0 )){
                result ++ ; 
            }
        }

        printf("%d\n" , result) ; 
    }
    return 0 ; 
}
View Code

 











以上是关于kuangbin专题五:B - The Suspects POJ - 1611的主要内容,如果未能解决你的问题,请参考以下文章

算法系列学习[kuangbin带你飞]专题十二 基础DP1 B - Ignatius and the Princess IV

kuangbin专题七 ZOJ1610 Count the Colors (灵活线段树)

kuangbin专题专题四 Til the Cows Come Home POJ - 2387

[kuangbin带你飞]专题一 简单搜索 E. Find The Multiple

kuangbin专题五:C - How Many Tables HDU - 1213

kuangbin专题五 并查集从入门到熟练4题