CDOJ 145 Earthquake

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了CDOJ 145 Earthquake相关的知识,希望对你有一定的参考价值。

After the big earthquake, a lot of roads have been destroyed, some towns are disconnected with each other.

In order to save the trapped as soon as possible, we need to try our best to rebuild the roads, and make sure all the towns will be reconnected(that is any villages is connected to the others with a clear route at least).

Unfortunately, we have only one team to rebuild the roads. Now,please tell us how long do you think these roads can be reconnected.

Input

The first line contains a number T denotes the number of test case.

For each test case,

In the first line, you will get two number N (1N1000) and M(1MN×N), denotes the number of towns and the number of roads.

The next M lines, each contains three number A,B,C, denotes there is a road between A and B that needed C (1×C×1000) minutes to rebuild.

Output

For each test case, you should output a line contains a number denotes the minimal time need to rebuild the roads so that all the towns are connected.

Sample input and output

Sample InputSample Output
2
3 3
1 2 3
2 3 3
3 1 7
3 3
1 2 3
2 3 3
3 1 1
6
4
#include <iostream>
#include <algorithm>
using namespace std;

int V,E,v[1005];
class edge {
public:
    int weight,from,to;
}e[1000005];

bool cmp(edge a,edge b) {
    return a.weight<b.weight;
}

int find(int x) {
    return (v[x]==x)?x:(v[x]=find(v[x]));
}

void MST() {
    int vnum=0,all_weight=0,x,y;
    for (int i=0; i<E&&vnum<V-1; i++) {
        x=find(e[i].from);
        y=find(e[i].to);
        if (x!=y) {
            v[x]=y;
            all_weight+=e[i].weight;
            vnum++;
        }
    }
    printf("%d\n",all_weight);
}

int main() {
    int t;
    scanf("%d",&t);
    while (t--) {
        scanf("%d%d",&V,&E);
        for (int i=0; i<V; i++)
            v[i]=i;
        for (int i=0; i<E; i++) {
            scanf("%d%d%d",&e[i].from,&e[i].to,&e[i].weight);
            e[i].from--;
            e[i].to--;
        }
        sort(e, e+E, cmp);
        MST();
    }
}

以上是关于CDOJ 145 Earthquake的主要内容,如果未能解决你的问题,请参考以下文章

线段树模板 CDOJ1057

[USACO09JAN]地震造成的破坏Earthquake Damage

P4951 [USACO01OPEN]Earthquake(二分&MST)

洛谷2944 [USACO09MAR]地震损失2Earthquake Damage 2

bzoj2987&luogu5171 Earthquake

Earthquake[USACO01OPEN]