1029. Median (25)

Posted 给杰瑞一块奶酪~

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1029. Median (25)相关的知识,希望对你有一定的参考价值。

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15, 16, 17} is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (<=1000000) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output

For each test case you should output the median of the two given sequences in a line.

Sample Input
4 11 12 13 14
5 9 10 15 16 17
Sample Output
13


排序
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <set>
#include <algorithm>
using namespace std;

long long s[2000000];
int main()
{
    int a,b;
    scanf("%d",&a);
    for(int i = 0;i < a;i ++)
    {
        scanf("%lld",&s[i]);
    }
    scanf("%d",&b);
    b += a;
    for(int i = a;i < b;i ++)
    {
        scanf("%lld",&s[i]);
    }
    sort(s,s+b);
    printf("%lld",s[(b-1)/2]);
}

 

以上是关于1029. Median (25)的主要内容,如果未能解决你的问题,请参考以下文章

1029. Median (25)

PAT Advanced 1029 Median (25分)

PAT (Advanced Level) 1029. Median (25)

1029 Median (25 分) 难度: 简单 / 知识点: 排序

PAT 甲级 1029 Median (25 分)(思维题,找两个队列的中位数,没想到)*

1029 Median