Palindrome

Posted CountingStars

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Palindrome相关的知识,希望对你有一定的参考价值。

title: HDU - 1513 

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.

InputYour program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from ‘A‘ to ‘Z‘, lowercase letters from ‘a‘ to ‘z‘ and digits from ‘0‘ to ‘9‘. Uppercase and lowercase letters are to be considered distinct. 
OutputYour program is to write to standard output. The first line contains one integer, which is the desired minimal number. 
Sample Input

5
Ab3bd

Sample Output

2
题意:给你一个字符串,问你最少需要增加几个字符才能使字符串变成回文串,题目很容易理解,而且之前在集训的时候有看过这种题目,但是因为自己的懒散,就没有及时补题,补题和写博客还是很重要啊!!!
分析:题目要求插入最少的字符数量,那我们就只需要求题目给出的字符串和其反向字符串的最长公共子序列,最后用字符串的长度减去最长公共子序列的长度就是要求的答案了!还有一个问题就是题目给出N的最大值为5000,但是开不了一个5000*5000的数组啊!那怎么办呢?使用滚动数组,每一个要求的答案都只与当前行和前一行有关,所以后面的覆盖前面的不会对最终结果造成影响,所以最终其实只需要两行,分奇偶进行存储就好了!
AC代码:
#include<iostream>
#include<cstring>
#include<cmath>
#define N 5050
typedef long long ll;
using namespace std;
char a[N],b[N];
int dp[10][N];
int Max(int x,int y)
{
    return x>y?x:y;
}
int main()
{
    int n;
    while (cin>>n)
    {
          for (int i=0;i<n;i++)
            cin>>a[i];
          memset(dp,0,sizeof(dp));
          for (int i=1;i<=n;i++)
            for (int j=1;j<=n;j++)
           {
               if (a[i-1]==a[n-j])
                 dp[i%2][j]=dp[(i-1)%2][j-1]+1;
               else if (a[i-1]!=a[n-j])
                 dp[i%2][j]=Max(dp[i%2][j-1],dp[(i-1)%2][j]);
           }
           cout << n-dp[n%2][n] << endl;
    }

    return 0;
}

 

以上是关于Palindrome的主要内容,如果未能解决你的问题,请参考以下文章

leetcode9. Palindrome Number

009.Palindrome Number

LeetCode:Palindrome Number

266. Palindrome Permutation

poj3974 Palindrome

codeforces 1045I Palindrome Pairs stl+构造