HDU 1160 DP最长子序列

Posted Arlenmbx

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 1160 DP最长子序列相关的知识,希望对你有一定的参考价值。

G - FatMouse‘s Speed
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Appoint description:

Description

FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
 

Input

Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed.
 

Output

Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that

W[m[1]] < W[m[2]] < ... < W[m[n]]

and

S[m[1]] > S[m[2]] > ... > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.
 

Sample Input

6008 1300 6000 2100 500 2000 1000 4000 1100 3000 6000 2000 8000 1400 6000 1200 2000 1900
 

Sample Output

4 4 5 9 7
 
 
正常一个·变量的求法变为结构体封装,,,,,,额外加一个pre数组记录回溯路径
1A~~~~
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn=1005;
struct node{
    int weight,speed,id;
}que[maxn];
int dp[maxn],pre[maxn];
bool cmp(struct node t1,struct node t2){
   if(t1.weight!=t2.weight)
    return t1.weight<t2.weight;
    return t1.speed>t2.speed;
}

int main(){
    int x,y;
    int tot;
    tot=1;
    while(scanf("%d%d",&que[tot].weight,&que[tot].speed)!=EOF){
        que[tot].id=tot;
        tot++;
    }
    sort(que+1,que+tot+1,cmp);
    memset(dp,0,sizeof(dp));
    memset(pre,-1,sizeof(pre));
    dp[1]=1;
    for(int i=2;i<tot;i++){
        dp[i]=1;
       for(int j=i-1;j>=1;j--){
           if((que[i].weight>que[j].weight)&&(que[i].speed<que[j].speed)&&dp[i]<dp[j]+1){
               dp[i]=dp[j]+1;
               pre[i]=j;
           }
       }
    }
     int point,ans=-1;
    for(int i=1;i<tot;i++){
          if(dp[i]>ans){
             ans=dp[i];
              point=i;
          }
    }
    printf("%d\n",ans);
    int tmp[maxn];
    int cnt=0;
    for(int i=point;i!=-1;i=pre[i]){
//       printf("%d\n",que[i].id);
        tmp[cnt++]=que[i].id;
    }
    for(int i=cnt-1;i>=0;i--)
    printf("%d\n",tmp[i]);

    return 0;
}

 

以上是关于HDU 1160 DP最长子序列的主要内容,如果未能解决你的问题,请参考以下文章

HDU 1160 FatMouse's Speed (动态规划最长下降子序列)

hdu 1087&1160 最长增序列问题

[HDU1160]FatMouse's Speed

dp求顺序hdu1160

HDU 1160 FatMouse's Speed (最长上升子序列)

hdu1160 LIS变形