POJ 1862 Stripies哈夫曼/贪心/优先队列

Posted Roni

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ 1862 Stripies哈夫曼/贪心/优先队列相关的知识,希望对你有一定的参考价值。

Stripies
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 18198   Accepted: 8175

Description

Our chemical biologists have invented a new very useful form of life called stripies (in fact, they were first called in Russian - polosatiki, but the scientists had to invent an English name to apply for an international patent). The stripies are transparent amorphous amebiform creatures that live in flat colonies in a jelly-like nutrient medium. Most of the time the stripies are moving. When two of them collide a new stripie appears instead of them. Long observations made by our scientists enabled them to establish that the weight of the new stripie isn‘t equal to the sum of weights of two disappeared stripies that collided; nevertheless, they soon learned that when two stripies of weights m1 and m2 collide the weight of resulting stripie equals to 2*sqrt(m1*m2). Our chemical biologists are very anxious to know to what limits can decrease the total weight of a given colony of stripies. 
You are to write a program that will help them to answer this question. You may assume that 3 or more stipies never collide together. 

Input

The first line of the input contains one integer N (1 <= N <= 100) - the number of stripies in a colony. Each of next N lines contains one integer ranging from 1 to 10000 - the weight of the corresponding stripie.

Output

The output must contain one line with the minimal possible total weight of colony with the accuracy of three decimal digits after the point.

Sample Input

3
72
30
50

Sample Output

120.000

Source

Northeastern Europe 2001, Northern Subregion
 
【代码】:
技术分享图片
#include<iostream>
#include<stdio.h>
#include<vector>
#include<queue>
#include<cmath>
using namespace std;

#define LL long long
using namespace std;
const int N = 20000+100;
int n;
double L;
double a,b;
priority_queue<double> q;
int main()
{
    cin>>n;

        for(int i=0;i<n;i++)
        {
            cin>>L;
            q.push(L);
        }
        while(q.size()>1)
        {
            a=q.top();q.pop();

            b=q.top();q.pop();

            q.push(2*sqrt(a*b));
        }
    printf("%.3f\n",q.top());

    return 0;
}
View Code

 

以上是关于POJ 1862 Stripies哈夫曼/贪心/优先队列的主要内容,如果未能解决你的问题,请参考以下文章

poj1862 Stripies

POJ 1862 - Stripies

POJ 1862 Stripies 题解 《挑战程序设计竞赛》

POJ 1862 Stripies 优先队列

POJ1862-Stripies

POJ - 3253 Fence Repair(贪心)