算法训练 最长字符串

Posted watchfree

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了算法训练 最长字符串相关的知识,希望对你有一定的参考价值。

算法训练 最长字符串  
时间限制:1.0s   内存限制:512.0MB
    
  求出5个字符串中最长的字符串。每个字符串长度在100以内,且全为小写字母。
样例输入
one two three four five
样例输出
three
import java.util.Scanner;
public class Main {

    public static void main(String[] args) {
        // TODO Auto-generated method stub
        Scanner sc=new Scanner(System.in);
        String str=sc.nextLine();
        String s[]=str.split(" ");
        int len=s[0].length(); 
        int p=0;
        for(int i=1;i<s.length;i++){
            if(len<s[i].length()){ 
                len=s[i].length();
                p=i;
            }
        }
        System.out.println(s[p]);

    }

}

 

以上是关于算法训练 最长字符串的主要内容,如果未能解决你的问题,请参考以下文章

《算法竞赛入门经典》3.3最长回文子串

算法训练 字串统计

算法训练 字串统计

2018年全国多校算法寒假训练营练习比赛(第五场)-C字符串问题(KMP)

试题 算法训练 字串统计

字符串处理算法最长连续字符及其出现次数的算法设计及C代码实现