Til the Cows Come Home

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Til the Cows Come Home相关的知识,希望对你有一定的参考价值。

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John‘s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.
Input
* Line 1: Two integers: T and N

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.
Output
* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
Sample Input
5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100
Sample Output
90
Hint
INPUT DETAILS:

There are five landmarks.

OUTPUT DETAILS:

Bessie can get home by following trails 4, 3, 2, and 1.
 
 
用了邻接表和队列
 
代码:
 
#include <iostream>
#include <map>
#include <queue>
#include <cmath>
#include <cstdio>
#include <algorithm>
#include <cstring>
#define inf 10001
using namespace std;
int first[4002],next[4002];
int u[4002],v[4002],w[4002];
int dis[1001],vis[1001];
int main()
{
    int N,T,k;
    cin>>T>>N;
    memset(dis,inf,sizeof(dis));
    memset(first,-1,sizeof(next));
    for(int i = 0;i < T;i ++)//无向图
    {
        cin>>u[i]>>v[i]>>w[i];
        u[T + i] = v[i];
        v[T + i] = u[i];
        w[T + i] = w[i];
    }
    for(int i = 0;i < T * 2;i ++)
    {
        next[i] = first[u[i]];
        first[u[i]] = i;
    }
    queue<int>q;
    q.push(N);//N点起始
    dis[N] = 0;
    vis[N] = 1;
    while(!q.empty())
    {
        k = first[q.front()];
        while(k != -1)
        {
            if(dis[q.front()] + w[k] < dis[v[k]])
            {
                dis[v[k]] = w[k] + dis[q.front()];
                if(!vis[v[k]])///如果v[k]没有入队,且到v[k]的距离宽松了,就入队
                {
                    vis[v[k]] = 1;
                    q.push(v[k]);
                }
            }
            k = next[k];
        }
        vis[q.front()] = 0;
        q.pop();
    }
    cout<<dis[1];//终点1
}

 

以上是关于Til the Cows Come Home的主要内容,如果未能解决你的问题,请参考以下文章

Til the cows Come Home

Til the Cows Come Home(最短路)

POJ - 2387 Til the Cows Come Home

POJ 2387 Til the Cows Come Home

POJ 2837 Til the Cows Come Home

POJ 2387 Til the Cows Come Home