HDU1159 && POJ1458:Common Subsequence(LCS)

Posted 邻家那小孩儿

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU1159 && POJ1458:Common Subsequence(LCS)相关的知识,希望对你有一定的参考价值。

Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.  The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 
 
Sample Input
abcfbc abfcab programming contest abcd mnp
 
Sample Output
4 2 0
 
 
//入门级问题,算法导论上很详细
 
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;

char str1[1005],str2[1005];
int len1,len2;
int dp[1005][1005];

void LCS()
{
    len1=strlen(str1);
    len2=strlen(str2);
    memset(dp,0,sizeof(dp));
    for(int i=1;i<=len1;i++)
    {
        for(int j=1;j<=len2;j++)
        {
            if(str1[i-1]==str2[j-1])
            dp[i][j]=dp[i-1][j-1]+1;
            else
            dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
        }
    }
}

int main()
{
    while(cin>>str1>>str2)
    {
        LCS();
        cout<<dp[strlen(str1)][strlen(str2)]<<endl;
    }
    return 0;
}

 

以上是关于HDU1159 && POJ1458:Common Subsequence(LCS)的主要内容,如果未能解决你的问题,请参考以下文章

hdu1159 poj1458 LCS裸题

hdu&&poj搜索题题号

poj1159(动态规划或者lcs求最长字串)

hdu1501&amp;&amp;poj2192 Zipper(DFS)

poj2243 &amp;&amp; hdu1372 Knight Moves(BFS)

扫描线三巨头 hdu1928&&hdu 1255 && hdu 1542 [POJ 1151]