poj1258最小生成树prim

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了poj1258最小生成树prim相关的知识,希望对你有一定的参考价值。

技术分享技术分享技术分享技术分享;i++) ans[0]+=ans[i];
        printf("%d\n",ans[0]);       

    }
    return 0;
}技术分享技术分享

Agri-Net

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 62406   Accepted: 25818

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

Source

技术分享
#include<iostream>
#include<cmath>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<algorithm>
#define inf 1<<29
using namespace std;
int n,s,p,x[510],y[510];
int dis[510][510],ans[510]={0};
void prim()
{
    bool hh[510];
    int v;
    for(int i=1;i<=p;i++)
    {
        ans[i]=dis[1][i];
        hh[i]=0;            
    }          
    for(int i=1;i<=p;i++)
    {
        int mi=inf;
        for(int j=1;j<=p;j++)
        {
            if(ans[j]<mi&&!hh[j]) {mi=ans[j];v=j;}        
        }        
        hh[v]=1;
        for(int j=1;j<=p;j++)
        {
            if(!hh[j]&&dis[v][j]<ans[j]) ans[j]=dis[v][j];        
        }
        
    }
}
int main()
{
    while(~scanf("%d",&p))          
    {
        for(int i=1;i<=p;i++)
        {
            for(int j=1;j<=p;j++)
            {
                scanf("%d",&dis[i][j]);             
            }        
        }      
        prim();
        ans[0]=0;
        for(int i=1;i<=p;i++) ans[0]+=ans[i];
        printf("%d\n",ans[0]);       

    }
    return 0;
}
View Code

 




以上是关于poj1258最小生成树prim的主要内容,如果未能解决你的问题,请参考以下文章

poj 1258 农场网络 最小生成树

Agri-Net POJ 1258(最小生成树模板)

最小生成树 prime poj1258

Prim算法的3个版本

POJ - 1258(最小生成树.prime)

POJ 1258(最小生成树+知识)