1044. Shopping in Mars (25)

Posted gaoren

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1044. Shopping in Mars (25)相关的知识,希望对你有一定的参考价值。

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=105), the total number of diamonds on the chain, and M (<=108), the amount that the customer has to pay. Then the next line contains N positive numbers D1 ... DN (Di<=103 for all i=1, ..., N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print "i-j" in a line for each pair of i <= j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output "i-j" for pairs of i <= j such that Di + ... + Dj > M with (Di + ... + Dj - M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

解题思路:看着输入输出例子就直接编码了,没审题(无奈),有个点(输出minimized的i-j)就卡着,查bug好久。利用队列来解就行,如果当前队列内的总和sum小于m,则继续入队,并且sum加上入队节点的值。如果sum值大于m值,前面队列中的节点就可以出队列了。
#include<iostream>
#include<queue>
#include<cstdio>
#include<cstring>
using namespace std;
struct Node{
	int index;
	int value;
}; 
struct point{
	int start;
	int stop;
};
vector<int>v;
vector<point>ve;
vector<int>v1;
queue<Node>q;
int main(){
	int n,m;
	scanf("%d%d",&n,&m);
	int i,j;
	int value;
	v1.resize(n+1);
	//memset(v1,0,sizeof(v1));
	for(i=0;i<n+1;i++){
		v1[i]=0;
	}
	for(i=0;i<n;i++){
		scanf("%d",&value);
		v.push_back(value);
		v1[i+1]=v1[i]+value;
	}
	int sum=0;
	bool flag = true;
	for(i=0;i<n;i++){
		Node node;
		point node1;
		sum+=v[i];
		node.index=i;
		node.value=v[i];
		q.push(node);
		while(!q.empty()){
			if(sum>m){
				node=q.front();
				q.pop();
				sum-=node.value;
				if(sum<m){
					node1.start=node.index+1;
					node1.stop=i+1;
					ve.push_back(node1);
				}
			}else if(sum==m){
				node=q.front();
				q.pop();
				sum-=node.value;
				printf("%d-%d\n",node.index+1,i+1);
				flag = false;
				break;
			}else{
				break;
			}
		}
	}
	int min=0xffffff;
	if(flag){
		int len=ve.size();
		for(i=0;i<len;i++){
			if(min>(v1[ve[i].stop]-v1[ve[i].start-1])){
				min=v1[ve[i].stop]-v1[ve[i].start-1];
			}
		}
		for(i=0;i<len;i++){
			if(min==v1[ve[i].stop]-v1[ve[i].start-1]){
				printf("%d-%d\n",ve[i].start,ve[i].stop);
			}
		}
	}
	return 0;
}

  

以上是关于1044. Shopping in Mars (25)的主要内容,如果未能解决你的问题,请参考以下文章

1044. Shopping in Mars (25)

1044. Shopping in Mars (25)

PAT 1044. Shopping in Mars

PAT 1044 Shopping in Mars[二分][难]

PAT甲级——A1044 Shopping in Mars

PTA(Advanced Level)1044.Shopping in Mars