1041. Be Unique (20)

Posted gaoren

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1041. Be Unique (20)相关的知识,希望对你有一定的参考价值。

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=105) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print "None" instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main(){
	int n;
	int num[10002];
	int a[100002];
	memset(num,0,sizeof(num));
	int i;
	scanf("%d",&n);
	for(i=0;i<n;i++){
		scanf("%d",&a[i]);
		num[a[i]]++;
	}
	int flag=0;
	for(i=0;i<n;i++){
		if(num[a[i]]==1){
			printf("%d\n",a[i]);
			flag=1;
			break;
		}
	}
	if(flag==0){
		printf("None\n");
	}
	return 0;
} 

  

以上是关于1041. Be Unique (20)的主要内容,如果未能解决你的问题,请参考以下文章

A1041 Be Unique (20 分)

1041. Be Unique (20)

1041 Be Unique (20)

PAT甲级1041 Be Unique (20 分)(多重集)

PAT 甲级 1041 Be Unique (20 分)(简单,一遍过)

PAT Advanced 1041 Be Unique (20分)