1008. Elevator

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1008. Elevator相关的知识,希望对你有一定的参考价值。

1008. Elevator (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:
3 2 3 1
Sample Output:
41
import java.util.Scanner;

public class Main {

    public static void main(String[] args) {
        Scanner in=new Scanner(System.in);
        int n=in.nextInt(),sum=0,now=0;
        while(n!=0){
            int a=in.nextInt();
            if(a>now){
                sum=sum+6*(a-now);
            }
            else if(a<now){
                sum=sum+4*(now-a);
                
            }
            sum=sum+5;
            now=a;
            n--;
        }
        System.out.println(sum);

    }

}

 

以上是关于1008. Elevator的主要内容,如果未能解决你的问题,请参考以下文章

1008 Elevator

HDU1008Elevator

A1008 Elevator (20分)

pat 1008 Elevator(20 分)

甲级1008 Elevator

1008 Elevator (20分)