poj2635The Embarrassed Cryptographer(同余膜定理)

Posted 勿忘初心0924

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了poj2635The Embarrassed Cryptographer(同余膜定理)相关的知识,希望对你有一定的参考价值。

The Embarrassed Cryptographer
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 15069   Accepted: 4132

Description

技术分享The young and very promising cryptographer Odd Even has implemented the security module of a large system with thousands of users, which is now in use in his company. The cryptographic keys are created from the product of two primes, and are believed to be secure because there is no known method for factoring such a product effectively.
What Odd Even did not think of, was that both factors in a key should be large, not just their product. It is now possible that some of the users of the system have weak keys. In a desperate attempt not to be fired, Odd Even secretly goes through all the users keys, to check if they are strong enough. He uses his very poweful Atari, and is especially careful when checking his boss‘ key.

Input

The input consists of no more than 20 test cases. Each test case is a line with the integers 4 <= K <= 10100 and 2 <= L <= 106. K is the key itself, a product of two primes. L is the wanted minimum size of the factors in the key. The input set is terminated by a case where K = 0 and L = 0.

Output

For each number K, if one of its factors are strictly less than the required L, your program should output "BAD p", where p is the smallest factor in K. Otherwise, it should output "GOOD". Cases should be separated by a line-break.

Sample Input

143 10
143 20
667 20
667 30
2573 30
2573 40
0 0

Sample Output

GOOD
BAD 11
GOOD
BAD 23
GOOD
BAD 31

/*
* @Author: lyucheng
* @Date:   2017-10-17 19:03:06
* @Last Modified by:   lyucheng
* @Last Modified time: 2017-10-17 16:50:37
*/
#include <stdio.h>
#include <vector>
#include <string.h>

#define MAXN 105
#define MAXM 1000005

using namespace std;

char str[MAXN];
int k;
int p[MAXM];
bool prime[MAXM];
int tol;
int num[MAXM];
vector<int>v;

void init(){
    tol=0;
    for(int i=2;i<MAXM;i++){
        if(prime[i]==false)
            p[tol++]=i;
        for(int j=0;j<tol&&i*p[j]<MAXM;j++){
            prime[i*p[j]]=true;
            if(i%p[j]==0)
                break;
        }
    }
}

bool ok(int k){
    int s=0;
    for(int i=(int)v.size()-1;i>=0;i--){
        s*=1000;
        s%=k;
        s+=v[i];
        s%=k;
    }
    if(s==0)
        return true;
    else 
        return false;     
}

int main(){
    // freopen("in.txt","r",stdin);
    init();
    while(scanf("%s%d",str,&k)!=EOF&&(str[0]-0!=0&&k!=0)){
        int n=strlen(str);
        v.clear();
        for(int i=n-1;i>=0;i-=3){
            int s=0;
            for(int j=max(0,i-2);j<=i;j++){
                s*=10;
                s+=str[j]-0;
            }
            v.push_back(s);
        }
        // for(int i=0;i<(int)v.size();i++){
        //     cout<<v[i]<<" ";
        // }cout<<endl;
        bool flag=true;
        for(int i=0;p[i]<k;i++){
            if(ok(p[i])==true){
                printf("BAD %d\n",p[i]);
                flag=false;
                break;
            }
        }
        if(flag==true)
            puts("GOOD");
    }
    return 0;
}

 

以上是关于poj2635The Embarrassed Cryptographer(同余膜定理)的主要内容,如果未能解决你的问题,请参考以下文章

[ACM] POJ 2635 The Embarrassed Cryptographer (同余定理,素数打表)

POJ - 2635 The Embarrassed Cryptographer(千进制+同余模)

POJ 2635 The Embarrassed Cryptographer(大数求余)

The Embarrassed Cryptographer POJ - 2635 同余模+高精度处理 +线性欧拉筛(每n位一起处理)

poj2635

POJ 2125 Destroying the Graph 二分图最小点权覆盖