洛谷 P2920 [USACO08NOV]时间管理Time Management

Posted 一蓑烟雨任生平

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了洛谷 P2920 [USACO08NOV]时间管理Time Management相关的知识,希望对你有一定的参考价值。

题目描述

Ever the maturing businessman, Farmer John realizes that he must manage his time effectively. He has N jobs conveniently numbered 1..N (1 <= N <= 1,000) to accomplish (like milking the cows, cleaning the barn, mending the fences, and so on).

To manage his time effectively, he has created a list of the jobs that must be finished. Job i requires a certain amount of time T_i (1 <= T_i <= 1,000) to complete and furthermore must be finished by time S_i (1 <= S_i <= 1,000,000). Farmer John starts his day at time t=0 and can only work on one job at a time until it is finished.

Even a maturing businessman likes to sleep late; help Farmer John determine the latest he can start working and still finish all the jobs on time.

作为一名忙碌的商人,约翰知道必须高效地安排他的时间.他有N工作要 做,比如给奶牛挤奶,清洗牛棚,修理栅栏之类的.

为了高效,列出了所有工作的清单.第i分工作需要T_i单位的时间来完成,而 且必须在S_i或之前完成.现在是0时刻.约翰做一份工作必须直到做完才能停 止.

所有的商人都喜欢睡懒觉.请帮约翰计算他最迟什么时候开始工作,可以让所有工作按时完 成.

输入输出格式

输入格式:

 

  • Line 1: A single integer: N

  • Lines 2..N+1: Line i+1 contains two space-separated integers: T_i and S_i

 

输出格式:

 

  • Line 1: The latest time Farmer John can start working or -1 if Farmer John cannot finish all the jobs on time.

 

输入输出样例

输入样例#1:
4 
3 5 
8 14 
5 20 
1 16 
输出样例#1:
2 

说明

Farmer John has 4 jobs to do, which take 3, 8, 5, and 1 units of time, respectively, and must be completed by time 5, 14, 20, and 16, respectively.

Farmer John must start the first job at time 2. Then he can do the second, fourth, and third jobs in that order to finish on time.

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
struct nond{
    int v,f;
}work[1005];
int n,ans;
bool cmp(nond x,nond y){
    return x.f>y.f;
}
int main(){
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
        scanf("%d%d",&work[i].v,&work[i].f);
    sort(work+1,work+1+n,cmp);
    ans=work[1].f;
    for(int i=1;i<=n;i++){
        if(ans<=work[i].f)    ans-=work[i].v;
        else    ans=work[i].f-work[i].v;
    }
    if(ans<0)    printf ("-1\n");
    else    printf ("%d\n",ans);
    return 0;
}

 

 

以上是关于洛谷 P2920 [USACO08NOV]时间管理Time Management的主要内容,如果未能解决你的问题,请参考以下文章

题解 P2920 [USACO08NOV]时间管理Time Management

洛谷 P2919 [USACO08NOV]守护农场Guarding the Farm

洛谷 P2915 [USACO08NOV]奶牛混合起来Mixed Up Cows

洛谷P2826 [USACO08NOV]光开关Light Switching [2017年6月计划 线段树02]

洛谷 P2916 [USACO08NOV]为母牛欢呼Cheering up the C…

洛谷 2915 [USACO08NOV]奶牛混合起来Mixed Up Cows