2017.10.15
Posted P_langen
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了2017.10.15相关的知识,希望对你有一定的参考价值。
描述有一个整型偶数n(2<= n <=10000),你要做的是:先把1到n中的所有奇数从小到大输出,再把所有的偶数从小到大输出。
- 输入
- 第一行有一个整数i(2<=i<30)表示有 i 组测试数据;
每组有一个整型偶数n。 - 输出
- 第一行输出所有的奇数
第二行输出所有的偶数 - 样例输入
-
2 10 14
- 样例输出
-
1 3 5 7 9 2 4 6 8 10 1 3 5 7 9 11 13 2 4 6 8 10 12 14
-
#include <stdio.h>
#include <stdlib.h>int main(int argc, char *argv[])
{
int i;
int j=1;
int k=0;
int t=0;
int m=0;
int a[30];
scanf("%d",&i);
for(t=0;t<i;t++)
scanf("%d",&a[t]);
for(m=0;m<t;m++)
{
while(j<a[m])
{
printf("%d ",j);
j+=2;
}
j=1;
printf("\n");
while(k<a[m])
{
k+=2;
printf("%d ",k);
}
k=0;
printf("\n");
}
return 0;
}
以上是关于2017.10.15的主要内容,如果未能解决你的问题,请参考以下文章