codves 2822 爱在心中

Posted 1 2 f s_____

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了codves 2822 爱在心中相关的知识,希望对你有一定的参考价值。

            2822 爱在心中
 时间限制: 1 s     空间限制: 128000 KB
 
题目描述 Description

“每个人都拥有一个梦,即使彼此不相同,能够与你分享,无论失败成功都会感动。爱因为在心中,平凡而不平庸,世界就像迷宫,却又让我们此刻相逢Our Home。”

在爱的国度里有N个人,在他们的心中都有着一个爱的名单,上面记载着他所爱的人(不会出现自爱的情况)。爱是具有传递性的,即如果A爱B,B爱C,则A也爱C。
如果有这样一部分人,他们彼此都相爱,则他们就超越了一切的限制,用集体的爱化身成为一个爱心天使。
现在,我们想知道在这个爱的国度里会出现多少爱心天使。而且,如果某个爱心天使被其他所有人或爱心天使所爱则请输出这个爱心天使是由哪些人构成的,否则输出-1。

输入描述 Input Description

第1行,两个数N、M,代表爱的国度里有N个人,爱的关系有M条。
第2到第M+1行,每行两个数A、B,代表A爱B。

输出描述 Output Description

第1行,一个数,代表爱的国度里有多少爱心天使。
第2行,如果某个爱心天使被其他所有人和爱心天使所爱则请输出这个爱心天使是由哪些人构成的(从小到大排序),否则输出-1。

样例输入 Sample Input

样例输入1:

6 7
1 2
2 3
3 2
4 2
4 5
5 6
6 4


样例输入2:

3 3
1 2
2 1
2 3

样例输出 Sample Output

样例输出1:

2
2 3

样例输出2:

1
-1

数据范围及提示 Data Size & Hint

各个测试点1s

解:强联通分量;

技术分享
#include<cstdio>
#include<cstring>
#include<algorithm>
using std::min;
const int N=100010; 
struct node
{
    int next,to,from;
}e[N],e2[N];
int first[N],first2[N];
int book[N];
int dfn[N],low[N],stack[N],cd[N];
int cnt=0;
void insert(int v,int u)
{
    e[++cnt].to=u;e[cnt].from=v;e[cnt].next=first[v];first[v]=cnt;
}
int tot=0,top=0,num=0;
int size[N],color[N];
void tarjan(int x)
{
    dfn[x]=low[x]=++tot;
    book[x]=1;stack[++top]=x;
    for(int i=first[x];i;i=e[i].next)
    {
        if(!dfn[e[i].to]) tarjan(e[i].to),low[x]=min(low[x],low[e[i].to]);
        else if(book[e[i].to])    low[x]=min(low[x],low[e[i].to]);
    }
    if(dfn[x]==low[x])
    {
        ++num;
        while(stack[top]!=x)
        {
            book[stack[top]]=0;
            color[stack[top]]=num;
            size[num]++;
            top--;
        }
        book[x]=0;
        color[x]=num;
        size[num]++;
        top--;
    }
}
void insert2(int v,int u)
{
    e2[++cnt].to=u;e2[cnt].next=first2[v];first2[v]=cnt;
}
int main()
{
    int n,m;
    scanf("%d %d",&n,&m);
    int v,u;
    for(int i=1;i<=m;i++)
    {
        scanf("%d %d",&v,&u);
        insert(v,u);
    }
    int ans=0;
    for(int i=1;i<=n;i++) if(!dfn[i]) tarjan(i);
    for(int i=1;i<=num;i++) if(size[i]!=1) ans++;
    printf("%d\n",ans);
    cnt=0;
    for(int i=1;i<=m;i++) 
    if(color[e[i].from]!=color[e[i].to]) cd[color[e[i].from]]++,insert(color[e[i].from],color[e[i].to]);
    ans=0;
    int aim=0;
//    printf("=======\n");
//    for(int i=1;i<=num;i++) 
//    {
//        printf("std:: %d , %d  ",i,cd[i]); 
//        for(int j=1;j<=n;j++) if(color[j]==i) printf("%d ",j);
//        printf("\n");
//    }
    for(int i=1;i<=num;i++) if(!cd[i]) ans++,aim=i;
    if(ans!=1) printf("-1");
    else 
    {
        if(size[aim]==1) printf("-1");
        else for(int i=1;i<=n;i++) if(color[i]==aim) printf("%d ",i);
    }
    return 0;
}
codves 2822

--------------

 


















以上是关于codves 2822 爱在心中的主要内容,如果未能解决你的问题,请参考以下文章

codevs 2822 爱在心中 tarjan(强联通分量)

codevs2822爱在心中

codevs2822爱在心中

codevs 2822 爱在心中

[CodeVS2822]爱在心中

强连通分量——爱在心中(codevs_2822)——tarjan求scc