Codevs 3143 二叉树的序遍历

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Codevs 3143 二叉树的序遍历相关的知识,希望对你有一定的参考价值。

题目描述 Description

求一棵二叉树的前序遍历,中序遍历和后序遍历

输入描述 Input Description

第一行一个整数n,表示这棵树的节点个数。

接下来n行每行2个整数L和R。第i行的两个整数Li和Ri代表编号为i的节点的左儿子编号和右儿子编号。

输出描述 Output Description

输出一共三行,分别为前序遍历,中序遍历和后序遍历。编号之间用空格隔开。

样例输入 Sample Input

5

2 3

4 5

0 0

0 0

0 0

样例输出 Sample Output

1 2 4 5 3

4 2 5 1 3

4 5 2 3 1

数据范围及提示 Data Size & Hint

n <= 16

题解:

#include <iostream>
using namespace std;
int l[20],r[20],flag;
void f(int x){
    if(flag==0) cout<<x<<" ";
    if(l[x]) f(l[x]);
    if(flag==1) cout<<x<<" ";
    if(r[x]) f(r[x]);
    if(flag==2) cout<<x<<" ";
}
int main()
{
    int n;
    cin>>n;
    for(int i=1;i<=n;++i)
    cin>>l[i]>>r[i];
    for(int i=0;i<=2;++i) {
        f(1);
        cout<<endl;
        flag+=1;
    }
    return 0;
}

 

以上是关于Codevs 3143 二叉树的序遍历的主要内容,如果未能解决你的问题,请参考以下文章

3143 二叉树的序遍历——http://codevs.cn/problem/3143/

3143 codevs 二叉树的序遍历

3143 二叉树的序遍历codevs

Codevs 3143 二叉树的序遍历

*题目记录 codevs3143 二叉树的序遍历

18.2.26 codevs3143 二叉树的序遍历