POJ 2378.Tree Cutting 树形dp

Posted GeekZRF

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ 2378.Tree Cutting 树形dp相关的知识,希望对你有一定的参考价值。

Tree Cutting
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 4834   Accepted: 2958

Description

After Farmer John realized that Bessie had installed a "tree-shaped" network among his N (1 <= N <= 10,000) barns at an incredible cost, he sued Bessie to mitigate his losses. 

Bessie, feeling vindictive, decided to sabotage Farmer John‘s network by cutting power to one of the barns (thereby disrupting all the connections involving that barn). When Bessie does this, it breaks the network into smaller pieces, each of which retains full connectivity within itself. In order to be as disruptive as possible, Bessie wants to make sure that each of these pieces connects together no more than half the barns on FJ. 

Please help Bessie determine all of the barns that would be suitable to disconnect.

Input

* Line 1: A single integer, N. The barns are numbered 1..N. 

* Lines 2..N: Each line contains two integers X and Y and represents a connection between barns X and Y.

Output

* Lines 1..?: Each line contains a single integer, the number (from 1..N) of a barn whose removal splits the network into pieces each having at most half the original number of barns. Output the barns in increasing numerical order. If there are no suitable barns, the output should be a single line containing the word "NONE".

Sample Input

10
1 2
2 3
3 4
4 5
6 7
7 8
8 9
9 10
3 8

Sample Output

3
8

Hint

INPUT DETAILS: 

The set of connections in the input describes a "tree": it connects all the barns together and contains no cycles. 

OUTPUT DETAILS: 

If barn 3 or barn 8 is removed, then the remaining network will have one piece consisting of 5 barns and two pieces containing 2 barns. If any other barn is removed then at least one of the remaining pieces has size at least 6 (which is more than half of the original number of barns, 5).

Source

 
题意:一棵n个节点的树,删除某个点使得子树的节点不超过n/2,输出这类点。
思路:树的重心。
代码:
技术分享
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<queue>
#include<stack>
#include<map>
#include<stack>
#include<set>
#include<bitset>
using namespace std;
#define PI acos(-1.0)
#define eps 1e-8
typedef long long ll;
typedef pair<int,int > P;
const int N=1e5+100,M=1e5+100;
const int inf=0x3f3f3f3f;
const ll INF=1e18+7,mod=1e9+7;
struct edge
{
    int from,to;
    ll w;
    int next;
};
int n;
edge es[M];
int cnt,head[N];
int deep[N],maxx[N];
void init()
{
    cnt=0;
    memset(head,-1,sizeof(head));
}
void addedge(int u,int v)
{
    cnt++;
    es[cnt].from=u,es[cnt].to=v;
    es[cnt].next=head[u];
    head[u]=cnt;
}
void dfs(int u,int fa)
{
    deep[u]=1;
    for(int i=head[u];i!=-1;i=es[i].next)
    {
        int  v=es[i].to;
        if(v==fa) continue;
        dfs(v,u);
        deep[u]+=deep[v];
        maxx[u]=max(maxx[u],deep[v]);
    }
    maxx[u]=max(maxx[u],n-deep[u]);
}
int main()
{
    while(~scanf("%d",&n))
    {
        init();
        for(int i=1;i<n;i++)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            addedge(u,v);
            addedge(v,u);
        }
        memset(deep,0,sizeof(deep));
        memset(maxx,0,sizeof(maxx));
        dfs(1,0);
        for(int i=1;i<=n;i++)
        {
            //cout<<i<<" * "<<maxx[i]<<endl;
            if(maxx[i]<=n/2) printf("%d\n",i);
        }
    }
    return 0;
}
树的重心

 

以上是关于POJ 2378.Tree Cutting 树形dp的主要内容,如果未能解决你的问题,请参考以下文章

POJ 2378 Tree Cutting(树的重心)

POJ 2378 Tree Cutting (DFS)

POJ 2378 Tree Cutting 子树统计

hdu5909 Tree Cutting(树形dp+fwt_xor优化转移)

hdu5909-Tree Cutting(树形dp)

HDU 5909 Tree Cutting (树形依赖型DP+点分治)