hdu 3336 Count the string

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hdu 3336 Count the string相关的知识,希望对你有一定的参考价值。

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11485    Accepted Submission(s): 5342


Problem Description
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.
 

 

Input
The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
 

 

Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.
 

 

Sample Input
1
4
abab
 

 

Sample Output
6
 

 

Author
 

 

Source
 

 

Recommend
lcy
 
 
 
kmp+dp
#include <cstring>
#include <cstdio>
#define Mod 10007
#define N 200005
int L,T,nextt[N],sum,f[N];
char str[N];
void get_next()
{
    int i=0,j=-1,len=strlen(str);
    nextt[i]=j;
    for(;i<len;)
    {
        if(j==-1||str[i]==str[j]) i++,j++,nextt[i]=j;
        else j=nextt[j];
    }
}
int main()
{
    scanf("%d",&T);
    for(;T--;)
    {
        memset(f,0,sizeof(f));sum=0;
        scanf("%d",&L);
        scanf("%s",str);
        get_next();
        f[0]=0;
        for(int i=1;i<=L;++i)
        {
            f[i]=f[nextt[i]]+1;
            sum=(sum+f[i])%Mod;
        }
        printf("%d\n",sum);
    }
    return 0;
}

 

以上是关于hdu 3336 Count the string的主要内容,如果未能解决你的问题,请参考以下文章

hdu 3336 Count the string

HDU 3336 Count the string

hdu 3336 Count the string

HDU 3336 Count the string

HDU 3336 Count the string (基础KMP)

HDU - 3336 Count the string (扩展kmp)