pat 1001

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了pat 1001相关的知识,希望对你有一定的参考价值。

1001. A+B Format (20)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.


Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

-1000000 9

Sample Output

-999,991
#include <iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<stack>
using namespace std;

int main() {
	
	int m,n;
	stack<char>ans;
	char c= ‘+‘;
	scanf("%d %d",&m,&n);
	int a =m+n;
	if(a<0){
	c=‘-‘;
	a=-a;	
	}
	
	if(a==0)
	printf("%d",a);
	//ans.push(c);
	int count=0;
	
	while(a!=0){
		char digit=(char)(a%10+‘0‘);
		a=a/10;
		ans.push(digit);
		count++;
		if(count%3==0){
			ans.push(‘,‘);
		}
	}
	if(c==‘-‘)
	printf("%c",c);
	if(!ans.empty()&&ans.top()==‘,‘)
	ans.pop();
//	printf("%d",a);
 	while(!ans.empty()){
 		printf("%c",ans.top());
 		ans.pop();
	 }
	printf("\n");
	return 0;
}


以上是关于pat 1001的主要内容,如果未能解决你的问题,请参考以下文章

PAT甲级考试题库1001 A+B Format 代码实现及相关知识学习

PAT1001

PAT--乙级-1001

PAT甲级 1001. A+B Format (20)

PAT乙级:(3n+1)猜想 (1001)

「日常训练」Battle Over Cities - Hard Version(PAT-TOP-1001)