Surprising Strings

Posted joeylee97

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Surprising Strings相关的知识,希望对你有一定的参考价值。

 

Surprising Strings
Time Limit: 1000MS        Memory Limit: 65536K
Total Submissions: 7403        Accepted: 4735
Description

The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of its D-pairs are different. A string is surprising if it is D-unique for every possible distance D.

Consider the string ZGBG. Its 0-pairs are ZG, GB, and BG. Since these three pairs are all different, ZGBG is 0-unique. Similarly, the 1-pairs of ZGBG are ZB and GG, and since these two pairs are different, ZGBG is 1-unique. Finally, the only 2-pair of ZGBG is ZG, so ZGBG is 2-unique. Thus ZGBG is surprising. (Note that the fact that ZG is both a 0-pair and a 2-pair of ZGBG is irrelevant, because 0 and 2 are different distances.)

Acknowledgement: This problem is inspired by the "Puzzling Adventures" column in the December 2003 issue of Scientific American.

Input

The input consists of one or more nonempty strings of at most 79 uppercase letters, each string on a line by itself, followed by a line containing only an asterisk that signals the end of the input.

Output

For each string of letters, output whether or not it is surprising using the exact output format shown below.

Sample Input

ZGBG
X
EE
AAB
AABA
AABB
BCBABCC
*
Sample Output

ZGBG is surprising.
X is surprising.
EE is surprising.
AAB is surprising.
AABA is surprising.
AABB is NOT surprising.
BCBABCC is NOT surprising.
Source

Mid-Central USA 2006
#include <iostream>
#include <cstdio>
#include<set>
#include <vector>
#include <cstring>
#include <list>
#include <queue>
#include <algorithm>
#include<functional>
#include <stack>
#define MAXN 200 + 3
#define INF 0x3f3f3f3f
using namespace std;
//直接枚举+hash+set 随便过
char s[MAXN];
inline int Hash(char a, char b)
{
    return (a - a) * 26 + b - a;
}
int main()
{
    ios::sync_with_stdio(0);
    while (cin >> s, s[0] != *)
    {
        set<int> S;
        int L = strlen(s);
        int l;
        for (l = 1; l < L; l++)
        {
            S.clear();
            for (int i = 0; i + l < L; i++)
                S.insert(Hash(s[i], s[i + l]));
            if (S.size() != L - l)
                break;
        }
        if (l == L)
            cout << s << " is surprising." << endl;
        else
            cout << s << " is NOT surprising." << endl;
    }
    return 0;
}

 

以上是关于Surprising Strings的主要内容,如果未能解决你的问题,请参考以下文章

Surprising Strings

Surprising Strings

POJ 3096 Surprising Strings

POJ 3096 Surprising Strings

[POJ3096]Surprising Strings

POJ 3096-Surprising Strings(set)