1201 最小数和最大数
Posted
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1201 最小数和最大数相关的知识,希望对你有一定的参考价值。
题目描述 Description
输入n个数,n<=100,找到其中最小的数和最大的数
输入描述 Input Description
第一行一个整数n
接下来一行n个整数,每个整数不超过231 -1
输出描述 Output Description
最小和最大的数
样例输入 Sample Input
4
1 2 3 4
样例输出 Sample Output
1 4
简单题:代码
#include<stdio.h>
int main()
{
int min,max,n,i,x;
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%d",&x);
if(i==0)//假定第一个数既是最大值也是最小值
{
min=x;
max=x;
}
else
{
if(max<x)
{
max=x;
}
if(min>x)
{
min=x;
}
}
}
printf("%d %d\n",min,max);
return 0;
}
以上是关于1201 最小数和最大数的主要内容,如果未能解决你的问题,请参考以下文章