LightOJ - 1148 Mad Counting(坑)

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了LightOJ - 1148 Mad Counting(坑)相关的知识,希望对你有一定的参考价值。

Time Limit: 500MS   Memory Limit: 32768KB   64bit IO Format: %lld & %llu

Status

Description

Mob was hijacked by the mayor of the Town "TruthTown". Mayor wants Mob to count the total population of the town. Now the naive approach to this problem will be counting people one by one. But as we all know Mob is a bit lazy, so he is finding some other approach so that the time will be minimized. Suddenly he found a poll result of that town where N people were asked "How many people in this town other than yourself support the same team as you in the FIFA world CUP 2010?" Now Mob wants to know if he can find the minimum possible population of the town from this statistics. Note that no people were asked the question more than once.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with an integer N (1 ≤ N ≤ 50). The next line will contain N integers denoting the replies (0 to 106) of the people.

Output

For each case, print the case number and the minimum possible population of the town.

Sample Input

2

4

1 1 2 2

1

0

Sample Output

Case 1: 5

Case 2: 1

Source

Problem Setter: Muhammad Rifayat Samee
Special Thanks: Jane Alam Jan

Status

什么鬼? 相等的话跳过只加被询问的人 ; 然后对最后相等的数进行处理相加 ;

 

#include <cstdio>
#include <algorithm>
#define N 51
int a[N];
using namespace std;
int main()
{
    int t; int Q=1; 
    scanf("%d", &t);
    while(t--)
    {
        int n;
        scanf("%d", &n);
        for(int i=0; i<n; i++)
            scanf("%d", &a[i]);
        sort(a, a+n);
        int cnt=0, sp=0;
        for(int i=0; i<n; i++)
        {
            if(i==0 || a[i]==a[i-1]) cnt++; 
            else
            {
                int k=(cnt+a[i-1]) / (a[i-1]+1);   
                sp=sp+k*(a[i-1] + 1);
                cnt=0; 
            }
        }
        sp=sp+(cnt+a[n-1])/(a[n-1]+1) *(a[n-1]+1);
        printf("Case %d: %d\n", Q++, sp);
    } 
    return 0;
}

 

 

 

以上是关于LightOJ - 1148 Mad Counting(坑)的主要内容,如果未能解决你的问题,请参考以下文章

TeradataDSA+NBU备份1148错误

#1148 - 此 MariaDB 版本不允许使用的命令

1148 Werewolf - Simple Version (20 分)

PAT_A1148#Werewolf - Simple Version

#'charmap'编解码器无法解码位置1148中的字节0x8d [重复]

XDOJ_1148_欧拉定理+快速幂