LightOJ - 1020 Childhood Game (博弈)

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了LightOJ - 1020 Childhood Game (博弈)相关的知识,希望对你有一定的参考价值。

Time Limit: 500MS   Memory Limit: 32768KB   64bit IO Format: %lld & %llu

Status

Description

Alice and Bob are playing a game with marbles; you may have played this game in childhood. The game is playing by alternating turns. In each turn a player can take exactly one or two marbles.

Both Alice and Bob know the number of marbles initially. Now the game can be started by any one. But the winning condition depends on the player who starts it. If Alice starts first, then the player who takes the last marble looses the game. If Bob starts first, then the player who takes the last marble wins the game.

Now you are given the initial number of marbles and the name of the player who starts first. Then you have to find the winner of the game if both of them play optimally.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer n (1 ≤ n < 231) and the name of the player who starts first.

Output

For each case, print the case number and the name of the winning player.

Sample Input

3

1 Alice

2 Alice

3 Bob

Sample Output

Case 1: Bob

Case 2: Alice

Case 3: Alice

Source

Problem Setter: Jane Alam Jan

Status

列举找规律 ;  

#include <cstdio>
#include <cstring>
int main()
{
    int t;
    scanf("%d", &t); int Q=1;
    while(t--)
    {
        int a; char name[15];
        scanf("%d%s", &a, name);
        if(strcmp(name, "Alice")==0)
        {
            if(a%3 ==1)
            {
                printf("Case %d: Bob\n", Q++);
            }
            else
            {
                printf("Case %d: Alice\n", Q++);
            }
        }
        if(strcmp(name, "Bob")==0)
        {
            if(a%3==0)
            {
                printf("Case %d: Alice\n", Q++);
            }
            else
            {
                printf("Case %d: Bob\n", Q++);
            }
        }
    }
    return 0;
}

 

 

以上是关于LightOJ - 1020 Childhood Game (博弈)的主要内容,如果未能解决你的问题,请参考以下文章

Light OJ 1020 - A Childhood Game

How childhood trauma affects health across a lifetime

[CF1586F]Defender of Childhood Dreams

CF 1583F(Defender of Childhood Dreams-构造)

CF 1583F(Defender of Childhood Dreams-构造)

lightoj 1234