CCF - 201312-1 - 出现次数最多的数

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了CCF - 201312-1 - 出现次数最多的数相关的知识,希望对你有一定的参考价值。

问题描述

试题编号: 201312-1
试题名称: 出现次数最多的数
时间限制: 1.0s
内存限制: 256.0MB
问题描述:
问题描述
  给定n个正整数,找出它们中出现次数最多的数。如果这样的数有多个,请输出其中最小的一个。
输入格式
  输入的第一行只有一个正整数n(1 ≤ n ≤ 1000),表示数字的个数。
  输入的第二行有n个整数s1, s2, …, sn (1 ≤ si ≤ 10000, 1 ≤ i ≤ n)。相邻的数用空格分隔。
输出格式
  输出这n个次数中出现次数最多的数。如果这样的数有多个,输出其中最小的一个。
样例输入
6
10 1 10 20 30 20
样例输出
10

思路

看似统计问题,问题在于如何统计。方法有二:
一是使用STL的map进行统计,是比较有效的办法。在同值的数比较多时,可以节省空间。
二是由于si介于1和10000之间,所以可以用一个数组进行统计。

代码

#include<stdio.h>
#include<string.h>
int main()
{
    int i,n,a[10001],b,max,maxc;
    scanf("%d",&n);
    memset(a,0,sizeof(a));
    for(i=1;i<=n;i++)
    {
        scanf("%d",&b);
        a[b]++;
    }
    max=1;
    maxc=0;
    for(i=1;i<=10000;i++)
    {
        if(a[i]>maxc)
        {
            maxc=a[i];
            max=i;
        }
    }
    printf("%d\n",max);
    return 0;
}
#include<iostream>
#include<map>
using namespace std;
int main()
{
    int i,n,b,max,maxc;
    map<int,int>a;
    scanf("%d",&n);
    for(i=1;i<=n;i++)
    {
        scanf("%d",&b);
        a[b]++;
    }
    max=1;
    maxc=0;
    for(map<int,int>::iterator it=a.begin();it!=a.end();it++)
    {
        if(it->second>maxc)
        {
            maxc=it->second;
            max=it->first;
        }
    }
    printf("%d\n",max);
    return 0;
}

 

以上是关于CCF - 201312-1 - 出现次数最多的数的主要内容,如果未能解决你的问题,请参考以下文章

CCF CSP 201312-1 出现次数最多的数

CCF 201312-1 出现次数最多的数 (水题)

ccf 201312-1 出现次数最多的数

CCF 201312-1 出现次数最多的数Java

CCF认证真题-(201312-1)-出现次数最多的数

CCF_201312-1_出现次数最多的数