2016中国大学生程序设计竞赛(ccpc 长春) Fraction模拟

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了2016中国大学生程序设计竞赛(ccpc 长春) Fraction模拟相关的知识,希望对你有一定的参考价值。

Problem Description

Mr. Frog recently studied how to add two fractions up, and he came up with an evil idea to trouble you by asking you to calculate the result of the formula below:
技术分享

As a talent, can you figure out the answer correctly?

Input

The first line contains only one integer T, which indicates the number of test cases.

For each test case, the first line contains only one integer n (n8).

The second line contains n integers: a1,a2,?an(1ai10).
The third line contains n integers: b1,b2,?,bn(1bi10).

Output

For each case, print a line “Case #x: p q”, where x is the case number (starting from 1) and p/q indicates the answer.

You should promise that p/q is irreducible.

Sample Input

1
2
1 1
2 3

Sample Output

Case #1: 1 2

Hint

Here are the details for the first sample:
2/(1+3/1) = 1/2
 
题意:读入n,输入两行数,第一行是a数组的n个数,第二行是b数组的n个数,按照题目如图所示模拟计算过程,最后结果分数化为最简。
思路:模拟。最后分子分母除以它们最大公约数即最简。
#include<stdio.h>
int a[20],b[20];

int gcd(int a,int b)
{
    int m;
    if( a < b)
        m = a,a=b,b=m;
    while(a%b)
    {
         m = a%b;
        a = b;
        b = m;
    }
    return b;
}

int main()
{
    int T,t,t2=0,i,n,j;
    int x,y;
    scanf("%d",&T);
    while(T --)
    {
        scanf("%d",&n);
        for(i = 1; i <= n; i ++)
            scanf("%d",&a[i]);
        for(i = 1; i <= n; i ++)
            scanf("%d",&b[i]);
        x = a[n-1]*a[n] + b[n];//初始化分子 
        y = a[n];//初始化分母 
        t = x;
        i = n-1;
        j = n-2;
        while(i>0||j>0)//循环模拟计算过程 
        {
            x = y*b[i--] + a[j--]*t;
            y = t;
            t = x; 
        }
        t = gcd(x,y);//求两数最大公约数 
        printf("Case #%d: %d %d\n",++t2,x/t,y/t);
    }
    return 0;
}

 

以上是关于2016中国大学生程序设计竞赛(ccpc 长春) Fraction模拟的主要内容,如果未能解决你的问题,请参考以下文章

ACM-CCPC中国大学生程序设计竞赛长春赛区(2016)地区赛——花开花落两相知

HDU 5914 Triangle 构造 (2016中国大学生程序设计竞赛(长春))

HDU 5912 Fraction 模拟 (2016中国大学生程序设计竞赛(长春))

2016中国大学生程序设计竞赛(ccpc 杭州)题解报告

2016中国大学生程序设计竞赛(ccpc 杭州)题解报告

2016中国大学生程序设计竞赛(长春)-重现赛 题解