HDU 1002 B - A + B Problem II
Posted ikefire
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 1002 B - A + B Problem II相关的知识,希望对你有一定的参考价值。
A + B Problem II
Time Limit: 2000/1000 MS (Java/Others)Total Submission(s): 372150
InputThe first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
OutputFor each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases. //格式要求!!!!!
Sample Input
2
1 2
112233445566778899 998877665544332211
Sample Output
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
题解:大整数加法,字符串输入,保存,转为int型,存入对应数组,满十进一
AC代码:
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
char a[1004],b[1004];
int aa[1004],bb[1004];
int main()
{
int t;
scanf("%d",&t);
int flag=0;
while(t--)
{
flag++;
printf("Case %d:\n",flag);
cin>>a>>b;
memset(aa,0,sizeof(aa));
memset(bb,0,sizeof(bb));
for(int i=strlen(a)-1,k=0;i>=0;i--,k++)
{
aa[k]=a[i]-‘0‘;
}
for(int i=strlen(b)-1,k=0;i>=0;i--,k++)
{
bb[k]=b[i]-‘0‘;
}
int max=strlen(a)>strlen(b)?strlen(a):strlen(b);
for(int i=0;i<max;i++)
{
aa[i+1]=aa[i+1]+(aa[i]+bb[i])/10;
aa[i]=(aa[i]+bb[i])%10;
}
printf("%s + %s = ",a,b);
int str=aa[max]>0?max:max-1;
for(int i=str;i>=0;i--)
{
printf("%d",aa[i]);
}
printf("\n");
if(t!=0)
printf("\n");
}
return 0;
}
今天也是元气满满的一天!good luck!
以上是关于HDU 1002 B - A + B Problem II的主要内容,如果未能解决你的问题,请参考以下文章