洛谷——P1596 [USACO10OCT]湖计数Lake Counting

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了洛谷——P1596 [USACO10OCT]湖计数Lake Counting相关的知识,希望对你有一定的参考价值。

P1596 [USACO10OCT]湖计数Lake Counting

题目描述

Due to recent rains, water has pooled in various places in Farmer John‘s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W‘) or dry land (‘.‘). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. Given a diagram of Farmer John‘s field, determine how many ponds he has.

由于近期的降雨,雨水汇集在农民约翰的田地不同的地方。我们用一个NxM(1<=N<=100;1<=M<=100)网格图表示。每个网格中有水(‘W‘) 或是旱地(‘.‘)。一个网格与其周围的八个网格相连,而一组相连的网格视为一个水坑。约翰想弄清楚他的田地已经形成了多少水坑。给出约翰田地的示意图,确定当中有多少水坑。

输入输出格式

输入格式:

 

Line 1: Two space-separated integers: N and M * Lines 2..N+1: M characters per line representing one row of Farmer John‘s field. Each character is either ‘W‘ or ‘.‘. The characters do not have spaces between them.

第1行:两个空格隔开的整数:N 和 M 第2行到第N+1行:每行M个字符,每个字符是‘W‘或‘.‘,它们表示网格图中的一排。字符之间没有空格。

 

输出格式:

 

Line 1: The number of ponds in Farmer John‘s field.

一行:水坑的数量

 

输入输出样例

输入样例#1:
10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.
输出样例#1:
3

说明

OUTPUT DETAILS: There are three ponds: one in the upper left, one in the lower left, and one along the right side.

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<algorithm>
#define N 110
using namespace std;
int n,m,ans,xx[8]={0,0,1,1,1,-1,-1,-1},yy[8]={1,-1,1,0,-1,1,0,-1};
char ch[N][N];
bool vis[N][N];
int read()
{
    int x=0,f=1;char ch=getchar();
    while(ch<0||ch>9){if(ch==-)f=-1; ch=getchar();}
    while(ch>=0&&ch<=9){x=x*10+ch-0; ch=getchar();}
    return x*f;
}
void dfs(int x,int y)
{
    if(x<0||y<0||x>n||y>m||vis[x][y]) return ;
    vis[x][y]=true;
    for(int i=0;i<8;i++)
    {
        if(ch[x+xx[i]][y+yy[i]]==W)
         dfs(x+xx[i],y+yy[i]);
    }
}
int main()
{
    n=read(),m=read();
    for(int i=1;i<=n;i++)
     for(int j=1;j<=m;j++)
      cin>>ch[i][j];
    for(int i=1;i<=n;i++)
     for(int j=1;j<=m;j++)
      if(ch[i][j]==W&&!vis[i][j])
       ans++,dfs(i,j);
    printf("%d",ans);
}

 

以上是关于洛谷——P1596 [USACO10OCT]湖计数Lake Counting的主要内容,如果未能解决你的问题,请参考以下文章

P1596 [USACO10OCT]湖计数Lake Counting

[USACO10OCT]湖计数Lake Counting 联通块

洛谷—— P1339 [USACO09OCT]热浪Heat Wave

洛谷——P2958 [USACO09OCT]木瓜的丛林Papaya Jungle

洛谷 P2959 [USACO09OCT]悠闲漫步The Leisurely Stroll

洛谷 P1649 [USACO07OCT]障碍路线Obstacle Course