题目1047:素数判定

Posted watchfree

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了题目1047:素数判定相关的知识,希望对你有一定的参考价值。

题目1047:素数判定

时间限制:秒内存限制:32 

题目描述:

给定一个数n,要求判断其是否为素数(0,1,负数都是非素数)。

输入:

测试数据有多组,每组输入一个数n

输出:

对于每组输入,若是素数则输出yes,否则输入no

样例输入:

13

样例输出:

yes

 */

/**************************************************************

Problem: 1047

User: watchfree

Language: Java

Result: Accepted

Time:80 ms

Memory:15452 kb

****************************************************************

import java.util.Scanner;
public class Main {
    static boolean judge(int n){
        if(n<=1) return false;
        if(n==2) return true;
         for(int i=2;i<=Math.sqrt(n);i++){
             if(n%i==0) return false;
         }
         return true;
    }

    public static void main(String[] args) {
        // TODO Auto-generated method stub
        Scanner sc=new Scanner(System.in);
        while(sc.hasNext()){
            int n=sc.nextInt();
            if(judge(n))
                System.out.println("yes");
            else
                System.out.println("no");
        }
        sc.close();

    }

}

 

以上是关于题目1047:素数判定的主要内容,如果未能解决你的问题,请参考以下文章

hdu 2012 素数判定

1702 素数判定 2

1702 素数判定 2

codevs——1430 素数判定

1057: 素数判定

《算法零基础100例》(第7例) 素数判定