洛谷P3398 仓鼠找sugar

Posted Soda

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了洛谷P3398 仓鼠找sugar相关的知识,希望对你有一定的参考价值。

P3398 仓鼠找sugar

题目描述

小仓鼠的和他的基(mei)友(zi)sugar住在地下洞穴中,每个节点的编号为1~n。地下洞穴是一个树形结构。这一天小仓鼠打算从从他的卧室(a)到餐厅(b),而他的基友同时要从他的卧室(c)到图书馆(d)。他们都会走最短路径。现在小仓鼠希望知道,有没有可能在某个地方,可以碰到他的基友?

小仓鼠那么弱,还要天天被zzq大爷虐,请你快来救救他吧!

输入输出格式

输入格式:

 

第一行两个正整数n和q,表示这棵树节点的个数和询问的个数。

接下来n-1行,每行两个正整数u和v,表示节点u到节点v之间有一条边。

接下来q行,每行四个正整数a、b、c和d,表示节点编号,也就是一次询问,其意义如上。

 

输出格式:

 

对于每个询问,如果有公共点,输出大写字母“Y”;否则输出“N”。

 

输入输出样例

输入样例#1:
5 5
2 5
4 2
1 3
1 4
5 1 5 1
2 2 1 4
4 1 3 4
3 1 1 5
3 5 1 4
输出样例#1:
Y
N
Y
Y
Y

说明

__本题时限1s,内存限制128M,因新评测机速度较为接近NOIP评测机速度,请注意常数问题带来的影响。__

20%的数据 n<=200,q<=200

40%的数据 n<=2000,q<=2000

70%的数据 n<=50000,q<=50000

100%的数据 n<=100000,q<=100000

技术分享
#include<iostream>
#include<cstring>
#include<cstdio>
#define maxn 100010
using namespace std;
int n,Q,num,head[maxn],q[maxn],cnt;
int fa[maxn],son[maxn],sz[maxn],top[maxn],dep[maxn];
bool vis[maxn];
struct node{
    int to,pre;
}e[maxn*2];
long long v[maxn],ans;
long long qread(){
    long long i=0;
    char ch=getchar();
    while(ch<0||ch>9)ch=getchar();
    while(ch<=9&&ch>=0){i=i*10+ch-0;ch=getchar();}
    return i;
}
void Insert(int from,int to){
    e[++num].to=to;
    e[num].pre=head[from];
    head[from]=num;
}
void dfs1(int father,int now){
    fa[now]=father;
    dep[now]=dep[father]+1;
    sz[now]=1;
    for(int i=head[now];i;i=e[i].pre){
        int to=e[i].to;
        if(to==father)continue;
        dfs1(now,to);
        sz[now]+=sz[to];
        if(sz[son[now]]<sz[to]||!son[now])son[now]=to;
    }
}
void dfs2(int father,int now){
    top[now]=father;
    if(son[now])dfs2(father,son[now]);
    for(int i=head[now];i;i=e[i].pre){
        int to=e[i].to;
        if(to==son[now]||to==fa[now])continue;
        dfs2(to,to);
    }
}
int Query_lca(int a,int b){
    while(top[a]!=top[b]){
        if(dep[top[a]]<dep[top[b]])swap(a,b);
        a=fa[top[a]];
    }
    if(dep[a]>dep[b])swap(a,b);
    return a;
}
int main(){
    //freopen("Cola.txt","r",stdin);
    scanf("%d%d",&n,&Q);
    int x,y;
    for(int i=1;i<n;i++){
        scanf("%d%d",&x,&y);
        Insert(x,y);
        Insert(y,x);
    }
    dfs1(0,1);
    dfs2(1,1);
    int a,b,c,d;
    for(int i=1;i<=Q;i++){
        scanf("%d%d%d%d",&a,&b,&c,&d);
        memset(vis,0,sizeof(vis));
        int lca=Query_lca(a,b);
        cnt=0;
        while(a!=lca){vis[a]=1;a=fa[a];}
        while(b!=lca){vis[b]=1;b=fa[b];}
        vis[lca]=1;
        bool flag=0;
        lca=Query_lca(c,d);
        if(vis[lca])flag=1;
        if(flag){printf("Y\n");continue;}
        while(c!=lca){if(vis[c]){flag=1;break;}c=fa[c];}
        if(flag){printf("Y\n");continue;}
        while(d!=lca){if(vis[d]){flag=1;break;}d=fa[d];}
        if(flag){printf("Y\n");continue;}
        if(!flag){printf("N\n");continue;}
    }
    return 0;
}
40分 树剖lca+暴力查找

 

以上是关于洛谷P3398 仓鼠找sugar的主要内容,如果未能解决你的问题,请参考以下文章

洛谷 P3398 仓鼠找sugar

洛谷 [P3398] 仓鼠找sugar

洛谷P3398 仓鼠找sugar

洛谷 P3398 仓鼠找sugar

洛谷P3398 仓鼠找sugar

[洛谷 P3398] 仓鼠找sugar