2017ACM/ICPC广西邀请赛-重现赛(感谢广西大学)

Posted BobHuang

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了2017ACM/ICPC广西邀请赛-重现赛(感谢广西大学)相关的知识,希望对你有一定的参考价值。

A Math Problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
You are given a positive integer n, please count how many positive integers k satisfy kkn.
 

 

Input
There are no more than 50 test cases.

Each case only contains a positivse integer n in a line.

1n1018
 

 

Output
For each test case, output an integer indicates the number of positive integers k satisfy kkn in a line.
 

 

Sample Input
1 4
 

 

Sample Output
1 2
 
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const ll N=437893890380859375;
int main()
{
    ll n;
    while(~scanf("%lld",&n))
    {
        if(n>=N)
            printf("15\n");
        else
        {
            for(int k=1; k<16; k++)
            {
                ll s=1;
                for(int i=0; i<k; i++)
                    s*=k;
                if(s>n)
                {
                    printf("%d\n",k-1);
                    break;
                }
            }
        }
    }
    return 0;
}

 

Covering

Time Limit: 5000/2500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
Bob‘s school has a big playground, boys and girls always play games here after school.

To protect boys and girls from getting hurt when playing happily on the playground, rich boy Bob decided to cover the playground using his carpets.

Meanwhile, Bob is a mean boy, so he acquired that his carpets can not overlap one cell twice or more.

He has infinite carpets with sizes of 1×2 and 2×1, and the size of the playground is 4×n.

Can you tell Bob the total number of schemes where the carpets can cover the playground completely without overlapping?
 

Input
There are no more than 5000 test cases. 

Each test case only contains one positive integer n in a line.

1n1018
 

Output
For each test cases, output the answer mod 1000000007 in a line.
 

Sample Input
1 2
 

Sample Output
1 5
#include <stdio.h>
#include <string.h>
const int MD=1e9+7;
typedef long long LL;
struct matrix
{
    LL mat[5][5];
};
matrix matmul(matrix a,matrix b,int n)
{
    int i,j,k;
    matrix c;
    memset(c.mat,0,sizeof(c.mat));
    for(i=0; i<n; i++)
    {
        for(j=0; j<n; j++)
        {
            for(k=0; k<n; k++)
            {
                c.mat[i][j]=(c.mat[i][j]+a.mat[i][k]*b.mat[k][j])%MD;
            }
        }
    }
    return c;
}
matrix matpow(matrix a,LL k,int n)
{
    matrix b;
    int i;
    memset(b.mat,0,sizeof(b.mat));
    for(i=0; i<n; i++) b.mat[i][i]=1;
    while(k)
    {
        if(k&1) b=matmul(a,b,n);
        a=matmul(a,a,n);
        k>>=1;
    }
    return b;
}
int main()
{
    LL k;
    matrix a,b;
    memset(a.mat,0,sizeof(a.mat));
    memset(b.mat,0,sizeof(b.mat));
    a.mat[0][0]=1,a.mat[2][0]=1,a.mat[3][0]=1;
    b.mat[0][0]=1,b.mat[0][1]=5,b.mat[0][2]=1,b.mat[0][3]=-1;
    b.mat[1][0]=1,b.mat[2][1]=1,b.mat[3][2]=1;
    while(~scanf("%lld",&k))
    {
        printf("%lld\n",(matmul(matpow(b,k,4),a,4).mat[0][0]+MD)%MD);
    }
    return 0;
}

 

CS Course

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
Little A has come to college and majored in Computer and Science.

Today he has learned bit-operations in Algorithm Lessons, and he got a problem as homework.

Here is the problem:

You are giving n non-negative integers a1,a2,?,an, and some queries.

A query only contains a positive integer p, which means you 
are asked to answer the result of bit-operations (and, or, xor) of all the integers except ap.
 

Input
There are no more than 15 test cases. 

Each test case begins with two positive integers n and p
in a line, indicate the number of positive integers and the number of queries.

2n,q105

Then n non-negative integers a1,a2,?,an follows in a line, 0ai109 for each i in range[1,n].

After that there are q positive integers p1,p2,?,pqin q lines, 1pin for each i in range[1,q].
 

Output
For each query p, output three non-negative integers indicates the result of bit-operations(and, or, xor) of all non-negative integers except ap in a line.
 

Sample Input
3 3 1 1 1 1 2 3
 

Sample Output
1 1 0 1 1 0 1 1 0

 

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int N=1e5+10;
int a[N],b[N];
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        memset(b,0,sizeof(b));
        int Xor=0,And=0xffffffff,Or=0;
        for(int i=1; i<=n; i++)
        {
            int x;
            scanf("%d",&x);
            a[i]=x;
            And&=x;
            Or|=x;
            Xor^=x;
            for(int j=0; x; j++,x>>=1)
                b[j]+=x%2;
        }
        while(m--)
        {
            int q;
            scanf("%d",&q);
            q=a[q];
            int A=And,O=Or,X=Xor;
            X=X^q;
            for(int j=0; j<=30; j++,q>>=1)
            {
                if(b[j]==n-1&&q%2==0)A+=(1<<j);
                if(b[j]==1&&q%2)O-=(1<<j);
            }
            printf("%d %d %d\n",A,O,X);
        }
    }
    return 0

 

以上是关于2017ACM/ICPC广西邀请赛-重现赛(感谢广西大学)的主要内容,如果未能解决你的问题,请参考以下文章

2017ACM/ICPC广西邀请赛

2017ACM/ICPC亚洲区沈阳站-重现赛(感谢东北大学)HDU6225.Little Boxes-大数加法

2016ACM/ICPC亚洲区大连站-重现赛(感谢大连海事大学)(6/10)

HDU 5974 A Simple Math Problem(数学解方程)——2016ACM/ICPC亚洲区大连站-重现赛(感谢大连海事大学)

2017 acm / icpc shenyang 双十一单身狗温馨重现赛

2016ACM/ICPC亚洲区大连站现场赛题解报告