HDU 2817 A sequence of numbers 整数快速幂

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 2817 A sequence of numbers 整数快速幂相关的知识,希望对你有一定的参考价值。

A sequence of numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4550    Accepted Submission(s): 1444

Problem Description
Xinlv wrote some sequences on the paper a long time ago, they might be arithmetic or geometric sequences. The numbers are not very clear now, and only the first three numbers of each sequence are recognizable. Xinlv wants to know some numbers in these sequences, and he needs your help.
 
Input
The first line contains an integer N, indicting that there are N sequences. Each of the following N lines contain four integers. The first three indicating the first three numbers of the sequence, and the last one is K, indicating that we want to know the K-th numbers of the sequence.

You can assume 0 < K <= 10^9, and the other three numbers are in the range [0, 2^63). All the numbers of the sequences are integers. And the sequences are non-decreasing.
 
Output
Output one line for each test case, that is, the K-th number module (%) 200907.
 
Sample Input
2
1 2 3 5
1 2 4 5
 
Sample Output
5 16
 
Source
 
Recommend
gaojie
 
 
题目大意:给一个数N,代表N组数据,接下来N行,每行前三个数代表等差或等比数列前三个数,求第K个数。。。
 
思路:分两种情况
等差数列:第K个数是a1+(k-1)*d
等比数列:第K个数是a1*(k-1)*q,公比为整数,K<=10^9,q的k次方用到整数快速幂
注意:__int64型
 
#include<iostream>
#define mod 200907
using namespace std;
__int64 mi(__int64 q,__int64 k)
{
    __int64 sum=1;
    while(k)
    {
    if(k&1) sum=(sum*q)%mod;
    q=(q*q)%mod;
    k>>=1;
    }//整数快速幂
    return sum;
}
int main()
{
    int t;
    __int64 a, b, c, k;
    cin>>t;while(t--)
    {
        cin>>a>>b>>c>>k;
        if(c-b==b-a)
        cout<<(a%mod+(k-1)%mod*((c-b)%mod))%mod<<endl;
        else
        cout<<(mi(c/b,--k)%mod*a%mod)%mod<<endl;
    }
    return 0;
} 

 

 
 
 
 

以上是关于HDU 2817 A sequence of numbers 整数快速幂的主要内容,如果未能解决你的问题,请参考以下文章

HDU 5496 Beauty of Sequence

hdu4675 GCD of Sequence

HDU 6274 Master of Sequence (暴力+下整除)

HDU 4675 GCD of Sequence(莫比乌斯反演 + 打表注意事项)题解

hdu4675 GCD of Sequence 莫比乌斯+组合数学

HDU 3415 Max Sum of Max-K-sub-sequence